summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb b/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb
new file mode 100644
index 0000000000..fae1da2686
--- /dev/null
+++ b/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "jsonref is a library for automatic dereferencing of JSON Reference objects for Python"
2HOMEPAGE = "https://github.com/gazpachoking/jsonref"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4ac1cccee5d43e11fc4eddcf445be64a"
5
6SRC_URI[sha256sum] = "32fe8e1d85af0fdefbebce950af85590b22b60f9e95443176adbde4e1ecea552"
7
8SRC_URI += "file://migrate-to-pdm-backend.patch"
9
10inherit pypi python_setuptools_build_meta
11
12BBCLASSEXTEND = "native nativesdk"
13
14DEPENDS += " \
15 ${PYTHON_PN}-pdm-native \
16 ${PYTHON_PN}-pdm-backend-native \
17"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-core \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-netclient \
23"