summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-chardet.inc
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 17:48:02 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commitc3d10cd377406fa3ce7286965bfe64c1b1c67a90 (patch)
tree5747dc4d7839c2133e1668a45e9b1aa9e9b24e5d /meta-python/recipes-devtools/python/python-chardet.inc
parent1dbe0e298140bd549345f6a21371dea507d36434 (diff)
downloadmeta-openembedded-c3d10cd377406fa3ce7286965bfe64c1b1c67a90.tar.gz
python3-chardet: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-chardet.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-chardet.inc23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python-chardet.inc b/meta-python/recipes-devtools/python/python-chardet.inc
deleted file mode 100644
index 6305299780..0000000000
--- a/meta-python/recipes-devtools/python/python-chardet.inc
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Universal encoding detector for Python 2 and 3"
2LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
4
5inherit pypi
6
7# setup.py of chardet needs this.
8DEPENDS += "${PYTHON_PN}-pytest-runner-native"
9
10SRC_URI[md5sum] = "7dd1ba7f9c77e32351b0a0cfacf4055c"
11SRC_URI[sha256sum] = "84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae"
12
13BBCLASSEXTEND = "native nativesdk"
14
15PACKAGES =+ "${PN}-cli"
16RDEPENDS_${PN}-cli = "${PN} "
17FILES_${PN}-cli += " \
18 ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \
19"
20
21RDEPENDS_${PN}_class-target += " \
22 ${PYTHON_PN}-logging \
23"