summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
diff options
context:
space:
mode:
authorCook, Samuel <samuel.cook@cornelisnetworks.com>2023-02-21 14:51:28 +0000
committerKhem Raj <raj.khem@gmail.com>2023-02-22 01:07:43 -0800
commit2e7903d8613ccf885b432fd1a9452c1f51094228 (patch)
treeb7897e14ff585a2c78f311c9c2a14941d7f741c8 /meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
parent227fca5ef5023514ccbed5487e708e0e29ffa3f0 (diff)
downloadmeta-openembedded-2e7903d8613ccf885b432fd1a9452c1f51094228.tar.gz
python-systemd: update from v234 to v235
Includes bugfix from v234 which won't run on python3.10 See: https://github.com/systemd/python-systemd/issues/107 Removes patches now no longer required as they are implemented in v235 drop setting md5 checksum for src_uri as it is no longer needed rename patch directory to match recipe name as python2 version of recipe is gone V235 released to PyPI on 11 Feb 23 https://pypi.org/project/systemd-python/235/ Signed-off-by: Samuel Cook <samuel.cook@cornelisnetworks.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
deleted file mode 100644
index b3180f29f2..0000000000
--- a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From a681a79472df85cdc8c052bc61fb8b9e7b9a6495 Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Sun, 27 Feb 2022 11:50:36 -0800
4Subject: [PATCH] setup.py: switch from distutils to setuptools
5
6In Python 3.10, distutils is deprecated and slated for removal in Python
73.12. It also prevents 'setup.py bdist_wheel' from building a wheel.
8
9Upstream-Status: Submitted
10[https://github.com/systemd/python-systemd/pull/103]
11
12Signed-off-by: Tim Orling <tim.orling@konsulko.com>
13---
14 setup.py | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/setup.py b/setup.py
18index 099819b..fe9c03a 100644
19--- a/setup.py
20+++ b/setup.py
21@@ -1,5 +1,5 @@
22 import sys, os
23-from distutils.core import setup, Extension
24+from setuptools import setup, Extension
25 from subprocess import Popen, PIPE, check_output
26
27 def call(*cmd):
28--
292.30.2
30