diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch | 30 |
1 files changed, 0 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch deleted file mode 100644 index b3180f29f2..0000000000 --- a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From a681a79472df85cdc8c052bc61fb8b9e7b9a6495 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Sun, 27 Feb 2022 11:50:36 -0800 | ||
4 | Subject: [PATCH] setup.py: switch from distutils to setuptools | ||
5 | |||
6 | In Python 3.10, distutils is deprecated and slated for removal in Python | ||
7 | 3.12. It also prevents 'setup.py bdist_wheel' from building a wheel. | ||
8 | |||
9 | Upstream-Status: Submitted | ||
10 | [https://github.com/systemd/python-systemd/pull/103] | ||
11 | |||
12 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
13 | --- | ||
14 | setup.py | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/setup.py b/setup.py | ||
18 | index 099819b..fe9c03a 100644 | ||
19 | --- a/setup.py | ||
20 | +++ b/setup.py | ||
21 | @@ -1,5 +1,5 @@ | ||
22 | import sys, os | ||
23 | -from distutils.core import setup, Extension | ||
24 | +from setuptools import setup, Extension | ||
25 | from subprocess import Popen, PIPE, check_output | ||
26 | |||
27 | def call(*cmd): | ||
28 | -- | ||
29 | 2.30.2 | ||
30 | |||