summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-systemd')
-rw-r--r--meta-python/recipes-devtools/python/python-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch42
-rw-r--r--meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch30
-rw-r--r--meta-python/recipes-devtools/python/python-systemd/endian.patch14
3 files changed, 0 insertions, 86 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch b/meta-python/recipes-devtools/python/python-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch
deleted file mode 100644
index d7085a8565..0000000000
--- a/meta-python/recipes-devtools/python/python-systemd/0001-Provide-implementation-of-strndupa-for-musl.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 8b639f9faf6199e47b9eae0698d01a22917b6abe Mon Sep 17 00:00:00 2001
2From: Tim Orling <timothy.t.orling@linux.intel.com>
3Date: Fri, 29 Dec 2017 09:17:17 -0800
4Subject: [PATCH] Provide implementation of strndupa for musl
5
6Reuse the approach from oe-core:
7/meta/recipes-core/systemd/systemd/0002-src-basic-missing.h-check-for-missing-strndupa.patch
8
9Original patch author: Emil Renner Berthing <systemd@esmil.dk>
10
11Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com
12---
13Upstream-Status: Pending
14
15 systemd/util.c | 11 +++++++++++
16 1 file changed, 11 insertions(+)
17
18diff --git a/systemd/util.c b/systemd/util.c
19index e02c825..277e611 100644
20--- a/systemd/util.c
21+++ b/systemd/util.c
22@@ -34,6 +34,17 @@
23
24 #include "util.h"
25
26+#if !HAVE_DECL_STRNDUPA
27+#define strndupa(s, n) \
28+ ({ \
29+ const char *__old = (s); \
30+ size_t __len = strnlen(__old, (n)); \
31+ char *__new = (char *)alloca(__len + 1); \
32+ __new[__len] = '\0'; \
33+ (char *)memcpy(__new, __old, __len); \
34+ })
35+#endif
36+
37 int safe_atou(const char *s, unsigned *ret_u) {
38 char *x = NULL;
39 unsigned long l;
40--
412.13.6
42
diff --git a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
deleted file mode 100644
index b3180f29f2..0000000000
--- a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From a681a79472df85cdc8c052bc61fb8b9e7b9a6495 Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Sun, 27 Feb 2022 11:50:36 -0800
4Subject: [PATCH] setup.py: switch from distutils to setuptools
5
6In Python 3.10, distutils is deprecated and slated for removal in Python
73.12. It also prevents 'setup.py bdist_wheel' from building a wheel.
8
9Upstream-Status: Submitted
10[https://github.com/systemd/python-systemd/pull/103]
11
12Signed-off-by: Tim Orling <tim.orling@konsulko.com>
13---
14 setup.py | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/setup.py b/setup.py
18index 099819b..fe9c03a 100644
19--- a/setup.py
20+++ b/setup.py
21@@ -1,5 +1,5 @@
22 import sys, os
23-from distutils.core import setup, Extension
24+from setuptools import setup, Extension
25 from subprocess import Popen, PIPE, check_output
26
27 def call(*cmd):
28--
292.30.2
30
diff --git a/meta-python/recipes-devtools/python/python-systemd/endian.patch b/meta-python/recipes-devtools/python/python-systemd/endian.patch
deleted file mode 100644
index e09aea7336..0000000000
--- a/meta-python/recipes-devtools/python/python-systemd/endian.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1Include endian.h for missing definitions of htobe16
2
3Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
5--- a/systemd/util.c
6+++ b/systemd/util.c
7@@ -28,6 +28,7 @@
8 #include <stdbool.h>
9 #include <assert.h>
10 #include <errno.h>
11+#include <endian.h>
12 #include <fcntl.h>
13 #include <unistd.h>
14 #include <net/if.h>