diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-02-22 19:15:10 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-24 09:07:24 -0800 |
commit | 606a07f6c5fed53846de53acbbf9ed29e481f395 (patch) | |
tree | 6c37e3d2bbbf571310685aff933ef37bcb6e5e24 /meta-python/recipes-devtools/python/python3-h5py | |
parent | c72839e6a4fb5a3da77dcfc23ed3f8ce18ed509b (diff) | |
download | meta-openembedded-606a07f6c5fed53846de53acbbf9ed29e481f395.tar.gz |
python3-h5py: Upgrade 2.10.0 -> 3.1.0
Upgrade to release 3.1.0:
- Fix using bytes as names for :meth:`~Group.create_dataset` and
 :meth:`~Group.create_virtual_dataset`.
- Fix writing data as a list to a dataset with a sub-array data
type.
- Preserve endianess in Cython dataset Reader
- If pytest is missing pytest-mpi then it will now fail
immediately with a clear warning message
- Fix a test which was failing on big-endian systems
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-h5py')
3 files changed, 35 insertions, 55 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch deleted file mode 100644 index 8c0b914326..0000000000 --- a/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | From 364fd0906efa349ea44a761820408dcf6b2b8726 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Tue, 29 Jan 2019 17:08:32 +0800 | ||
4 | Subject: [PATCH] cross compiling support | ||
5 | |||
6 | Remove useless dirs | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | |||
10 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
11 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
12 | --- | ||
13 | setup_build.py | 4 ---- | ||
14 | setup_configure.py | 2 +- | ||
15 | 2 files changed, 1 insertion(+), 5 deletions(-) | ||
16 | |||
17 | diff --git a/setup_build.py b/setup_build.py | ||
18 | index c0e9a28c..ffd3bef7 100644 | ||
19 | --- a/setup_build.py | ||
20 | +++ b/setup_build.py | ||
21 | @@ -55,10 +55,6 @@ if sys.platform.startswith('win'): | ||
22 | ('_HDF5USEDLL_', None), | ||
23 | ('H5_BUILT_AS_DYNAMIC_LIB', None) | ||
24 | ]) | ||
25 | -else: | ||
26 | - FALLBACK_PATHS['include_dirs'].extend(['/opt/local/include', '/usr/local/include']) | ||
27 | - FALLBACK_PATHS['library_dirs'].extend(['/opt/local/lib', '/usr/local/lib']) | ||
28 | - | ||
29 | |||
30 | class h5py_build_ext(build_ext): | ||
31 | |||
32 | diff --git a/setup_configure.py b/setup_configure.py | ||
33 | index 5576775e..75f4141e 100644 | ||
34 | --- a/setup_configure.py | ||
35 | +++ b/setup_configure.py | ||
36 | @@ -206,7 +206,7 @@ def autodetect_version(hdf5_dir=None): | ||
37 | default_path = 'libhdf5.so' | ||
38 | regexp = re.compile(r'^libhdf5.so') | ||
39 | |||
40 | - libdirs = ['/usr/local/lib', '/opt/local/lib'] | ||
41 | + libdirs = [] | ||
42 | try: | ||
43 | if pkgconfig.exists("hdf5"): | ||
44 | libdirs.extend(pkgconfig.parse("hdf5")['library_dirs']) | ||
45 | -- | ||
46 | 2.17.1 | ||
47 | |||
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch new file mode 100644 index 0000000000..4881b023c8 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From e6c0d487fb5e6063305b8b3187896fbfe5720ed2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Leon Anavi <leon.anavi@konsulko.com> | ||
3 | Date: Mon, 22 Feb 2021 18:42:43 +0200 | ||
4 | Subject: [PATCH] setup.py: Fix numpy version | ||
5 | |||
6 | Fix numpy version to ensure bitbake will find the pip package. | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | |||
10 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
11 | |||
12 | --- | ||
13 | setup.py | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/setup.py b/setup.py | ||
17 | index 7dbe583..6602c97 100755 | ||
18 | --- a/setup.py | ||
19 | +++ b/setup.py | ||
20 | @@ -49,7 +49,7 @@ SETUP_REQUIRES = [ | ||
21 | f"Cython >=0.29; python_version<'3.8'", | ||
22 | f"Cython >=0.29.14; python_version>='3.8'", | ||
23 | ] + [ | ||
24 | - f"numpy =={np_min}; python_version{py_condition}" | ||
25 | + f"numpy >={np_min}; python_version{py_condition}" | ||
26 | for np_min, py_condition in NUMPY_MIN_VERSIONS | ||
27 | ] | ||
28 | |||
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch index da95ee7af5..d0c2ece19b 100644 --- a/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch +++ b/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From b5d5a7efc7aaa2be830731001ed17c5b71bcefb1 Mon Sep 17 00:00:00 2001 | 1 | From 1a46082d0889a784037952c4da0cde3822849032 Mon Sep 17 00:00:00 2001 |
2 | From: Mingli Yu <mingli.yu@windriver.com> | 2 | From: Mingli Yu <mingli.yu@windriver.com> |
3 | Date: Fri, 29 Jan 2021 02:33:06 +0000 | 3 | Date: Thu, 28 Jan 2021 18:44:10 -0800 |
4 | Subject: [PATCH] setup_build.py: avoid absolute path | 4 | Subject: [PATCH] setup_build.py: avoid absolute path |
5 | 5 | ||
6 | Prevent absolute path from ending up in the egg-info SOURCES.txt. | 6 | Prevent absolute path from ending up in the egg-info SOURCES.txt. |
@@ -8,15 +8,17 @@ Prevent absolute path from ending up in the egg-info SOURCES.txt. | |||
8 | Upstream-Status: Submitted [https://github.com/h5py/h5py/pull/1803] | 8 | Upstream-Status: Submitted [https://github.com/h5py/h5py/pull/1803] |
9 | 9 | ||
10 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | 10 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> |
11 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
12 | |||
11 | --- | 13 | --- |
12 | setup_build.py | 2 +- | 14 | setup_build.py | 2 +- |
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | 15 | 1 file changed, 1 insertion(+), 1 deletion(-) |
14 | 16 | ||
15 | diff --git a/setup_build.py b/setup_build.py | 17 | diff --git a/setup_build.py b/setup_build.py |
16 | index ffd3bef..fb196c0 100644 | 18 | index 3c7c7ad..d824bdd 100644 |
17 | --- a/setup_build.py | 19 | --- a/setup_build.py |
18 | +++ b/setup_build.py | 20 | +++ b/setup_build.py |
19 | @@ -20,7 +20,7 @@ import api_gen | 21 | @@ -21,7 +21,7 @@ from setup_configure import BuildConfig |
20 | 22 | ||
21 | 23 | ||
22 | def localpath(*args): | 24 | def localpath(*args): |
@@ -24,7 +26,4 @@ index ffd3bef..fb196c0 100644 | |||
24 | + return op.join(*args) | 26 | + return op.join(*args) |
25 | 27 | ||
26 | 28 | ||
27 | MODULES = ['defs','_errors','_objects','_proxy', 'h5fd', 'h5z', | 29 | MODULES = ['defs', '_errors', '_objects', '_proxy', 'h5fd', 'h5z', |
28 | -- | ||
29 | 2.29.2 | ||
30 | |||