summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-01 12:04:27 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-03 08:05:21 -0700
commitb8bbcd4dea422be57123d75fbf77db6d33542b06 (patch)
tree17575e74c76687ac01ecdd69aed7a71614941326 /meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch
parent57baca4bc1b681482bc014508d28f7def5949c33 (diff)
downloadmeta-openembedded-b8bbcd4dea422be57123d75fbf77db6d33542b06.tar.gz
python3-m2crypto: Upgrade to 0.37.1
Unifiy .inc into .bb Add patches to fix issues with openssl 1.1.x Remove m2crypto-0.26.4-gcc_macros patch, its no longer needed Refresh existing patches Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch b/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch
new file mode 100644
index 0000000000..f039ae8665
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch
@@ -0,0 +1,31 @@
1Do not compute platform, this does not work in cross compile environment
2since it pokes at the system for getting architecture values
3
4Upstream-Status: Inappropriate
5Signed-off-by: Khem Raj <raj.khem@gmail.com>
6
7--- a/setup.py
8+++ b/setup.py
9@@ -169,22 +169,6 @@ class _M2CryptoBuildExt(build_ext.build_
10 log.debug('self.include_dirs = %s', self.include_dirs)
11 log.debug('self.library_dirs = %s', self.library_dirs)
12
13- if platform.system() == "Linux":
14- # For RedHat-based distros, the '-D__{arch}__' option for
15- # Swig needs to be normalized, particularly on i386.
16- mach = platform.machine().lower()
17- if mach in ('i386', 'i486', 'i586', 'i686'):
18- arch = '__i386__'
19- elif mach in ('ppc64', 'powerpc64', 'ppc64le', 'ppc64el'):
20- arch = '__powerpc64__'
21- elif mach in ('ppc', 'powerpc'):
22- arch = '__powerpc__'
23- else:
24- arch = '__%s__' % mach
25- self.swig_opts.append('-D%s' % arch)
26- if mach in ('ppc64le', 'ppc64el'):
27- self.swig_opts.append('-D_CALL_ELF=2')
28-
29 self.swig_opts.extend(['-I%s' % i for i in self.include_dirs])
30
31 # Some Linux distributor has added the following line in