diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch b/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch new file mode 100644 index 0000000000..f039ae8665 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | Do not compute platform, this does not work in cross compile environment | ||
2 | since it pokes at the system for getting architecture values | ||
3 | |||
4 | Upstream-Status: Inappropriate | ||
5 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
6 | |||
7 | --- a/setup.py | ||
8 | +++ b/setup.py | ||
9 | @@ -169,22 +169,6 @@ class _M2CryptoBuildExt(build_ext.build_ | ||
10 | log.debug('self.include_dirs = %s', self.include_dirs) | ||
11 | log.debug('self.library_dirs = %s', self.library_dirs) | ||
12 | |||
13 | - if platform.system() == "Linux": | ||
14 | - # For RedHat-based distros, the '-D__{arch}__' option for | ||
15 | - # Swig needs to be normalized, particularly on i386. | ||
16 | - mach = platform.machine().lower() | ||
17 | - if mach in ('i386', 'i486', 'i586', 'i686'): | ||
18 | - arch = '__i386__' | ||
19 | - elif mach in ('ppc64', 'powerpc64', 'ppc64le', 'ppc64el'): | ||
20 | - arch = '__powerpc64__' | ||
21 | - elif mach in ('ppc', 'powerpc'): | ||
22 | - arch = '__powerpc__' | ||
23 | - else: | ||
24 | - arch = '__%s__' % mach | ||
25 | - self.swig_opts.append('-D%s' % arch) | ||
26 | - if mach in ('ppc64le', 'ppc64el'): | ||
27 | - self.swig_opts.append('-D_CALL_ELF=2') | ||
28 | - | ||
29 | self.swig_opts.extend(['-I%s' % i for i in self.include_dirs]) | ||
30 | |||
31 | # Some Linux distributor has added the following line in | ||