diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-01-29 21:32:30 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-01 10:44:55 -0800 |
commit | 5fc34f7850e6ced6a4320a9a6da93800d162a22c (patch) | |
tree | 2de446bfd5e67c89cad947b4650c12b714eba91f /meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch | |
parent | 59506ec90ea39230ff29e2c4e1f1be6419ff8796 (diff) | |
download | meta-openembedded-5fc34f7850e6ced6a4320a9a6da93800d162a22c.tar.gz |
python3-prctl: Upgrade 1.7 -> 1.8.1
Upgrade to release 1.8.1:
- Master was renamed to main
- Backwards compatibility fixes
- Install dependencies before trying to build/publish
License-Update: Update year
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch | 11 |
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch b/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch index 775ae1b2e2..98d250c74c 100644 --- a/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch +++ b/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 9a16800738547d117284354bbcad7dd77d9d0344 Mon Sep 17 00:00:00 2001 | 1 | From 5f3911737c63a098caf73f1365320fe1b3a7638b Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Thu, 21 Apr 2016 03:05:57 -0400 | 3 | Date: Thu, 21 Apr 2016 03:05:57 -0400 |
4 | Subject: [PATCH] support cross-complication | 4 | Subject: [PATCH] support cross-complication |
@@ -6,12 +6,13 @@ Subject: [PATCH] support cross-complication | |||
6 | Upstream-Status: Inappropriate [oe specific] | 6 | Upstream-Status: Inappropriate [oe specific] |
7 | 7 | ||
8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | 8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
9 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
9 | --- | 10 | --- |
10 | setup.py | 35 ----------------------------------- | 11 | setup.py | 35 ----------------------------------- |
11 | 1 file changed, 35 deletions(-) | 12 | 1 file changed, 35 deletions(-) |
12 | 13 | ||
13 | diff --git a/setup.py b/setup.py | 14 | diff --git a/setup.py b/setup.py |
14 | index 658d1a5..e8be7eb 100755 | 15 | index eb83cfe..3f9567b 100755 |
15 | --- a/setup.py | 16 | --- a/setup.py |
16 | +++ b/setup.py | 17 | +++ b/setup.py |
17 | @@ -13,41 +13,6 @@ import sys | 18 | @@ -13,41 +13,6 @@ import sys |
@@ -38,13 +39,13 @@ index 658d1a5..e8be7eb 100755 | |||
38 | - sys.stderr.write("You need to install gcc to build this module\n") | 39 | - sys.stderr.write("You need to install gcc to build this module\n") |
39 | - sys.exit(1) | 40 | - sys.exit(1) |
40 | - | 41 | - |
41 | -sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE) | 42 | -sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE, env=os.environ) |
42 | -sp.communicate('#include <sys/prctl.h>\n'.encode()) | 43 | -sp.communicate('#include <sys/prctl.h>\n'.encode()) |
43 | -if sp.returncode: | 44 | -if sp.returncode: |
44 | - sys.stderr.write("You need to install libc development headers to build this module\n") | 45 | - sys.stderr.write("You need to install libc development headers to build this module\n") |
45 | - exit = True | 46 | - exit = True |
46 | - | 47 | - |
47 | -sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE) | 48 | -sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE, env=os.environ) |
48 | -sp.communicate('#include <sys/capability.h>\n'.encode()) | 49 | -sp.communicate('#include <sys/capability.h>\n'.encode()) |
49 | -if sp.returncode: | 50 | -if sp.returncode: |
50 | - sys.stderr.write("You need to install libcap development headers to build this module\n") | 51 | - sys.stderr.write("You need to install libcap development headers to build this module\n") |
@@ -57,5 +58,5 @@ index 658d1a5..e8be7eb 100755 | |||
57 | sources = ['_prctlmodule.c'], | 58 | sources = ['_prctlmodule.c'], |
58 | depends = ['securebits.h'], | 59 | depends = ['securebits.h'], |
59 | -- | 60 | -- |
60 | 2.8.1 | 61 | 2.17.1 |
61 | 62 | ||