diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-06-22 20:58:34 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-06-24 12:54:18 -0700 |
commit | 60b44507d9d15c94f322cd8dbb80aedc48e70556 (patch) | |
tree | dcdec66abeb15beda723bfbaff9d7fecf3252d80 /meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb | |
parent | 9e456c6908d2579657674c7cb41934c24ddb9ef7 (diff) | |
download | meta-openembedded-60b44507d9d15c94f322cd8dbb80aedc48e70556.tar.gz |
python3-py-cpuinfo: Add ptests
Add missing dependency on python3-io for cStringIO
Remove comment about missing modules since _winreg is windows specific
and cStringIO is addressed
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb | 21 |
1 files changed, 14 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb b/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb index 1f81a83230..1b62a7611f 100644 --- a/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb +++ b/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb | |||
@@ -8,13 +8,20 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b0b97c022f12b14d9e02de0b283ee9e9" | |||
8 | 8 | ||
9 | SRC_URI[sha256sum] = "5f269be0e08e33fd959de96b34cd4aeeeacac014dd8305f70eb28d06de2345c5" | 9 | SRC_URI[sha256sum] = "5f269be0e08e33fd959de96b34cd4aeeeacac014dd8305f70eb28d06de2345c5" |
10 | 10 | ||
11 | inherit pypi setuptools3 | 11 | inherit ptest pypi setuptools3 |
12 | 12 | ||
13 | RDEPENDS_${PN} += "python3-core python3-ctypes python3-datetime python3-json python3-mmap python3-multiprocessing python3-netclient python3-pickle python3-pprint python3-shell" | 13 | SRC_URI += "file://run-ptest \ |
14 | " | ||
15 | |||
16 | do_install_ptest() { | ||
17 | install -d ${D}${PTEST_PATH}/tests | ||
18 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
19 | } | ||
20 | |||
21 | RDEPENDS_${PN}-ptest += "\ | ||
22 | python3-pytest \ | ||
23 | " | ||
24 | |||
25 | RDEPENDS_${PN} += "python3-core python3-ctypes python3-datetime python3-json python3-io python3-mmap python3-multiprocessing python3-netclient python3-pickle python3-pprint python3-shell" | ||
14 | 26 | ||
15 | # WARNING: We were unable to map the following python package/module | ||
16 | # dependencies to the bitbake packages which include them: | ||
17 | # _winreg | ||
18 | # cStringIO | ||
19 | # winreg | ||
20 | BBCLASSEXTEND = "native nativesdk" | 27 | BBCLASSEXTEND = "native nativesdk" |