summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb21
1 files changed, 14 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb b/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb
index 1f81a83230..1b62a7611f 100644
--- a/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-py-cpuinfo_8.0.0.bb
@@ -8,13 +8,20 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b0b97c022f12b14d9e02de0b283ee9e9"
8 8
9SRC_URI[sha256sum] = "5f269be0e08e33fd959de96b34cd4aeeeacac014dd8305f70eb28d06de2345c5" 9SRC_URI[sha256sum] = "5f269be0e08e33fd959de96b34cd4aeeeacac014dd8305f70eb28d06de2345c5"
10 10
11inherit pypi setuptools3 11inherit ptest pypi setuptools3
12 12
13RDEPENDS_${PN} += "python3-core python3-ctypes python3-datetime python3-json python3-mmap python3-multiprocessing python3-netclient python3-pickle python3-pprint python3-shell" 13SRC_URI += "file://run-ptest \
14 "
15
16do_install_ptest() {
17 install -d ${D}${PTEST_PATH}/tests
18 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
19}
20
21RDEPENDS_${PN}-ptest += "\
22 python3-pytest \
23"
24
25RDEPENDS_${PN} += "python3-core python3-ctypes python3-datetime python3-json python3-io python3-mmap python3-multiprocessing python3-netclient python3-pickle python3-pprint python3-shell"
14 26
15# WARNING: We were unable to map the following python package/module
16# dependencies to the bitbake packages which include them:
17# _winreg
18# cStringIO
19# winreg
20BBCLASSEXTEND = "native nativesdk" 27BBCLASSEXTEND = "native nativesdk"