diff options
author | Ross Burton <ross.burton@arm.com> | 2022-07-14 13:43:59 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-07-15 12:48:34 -0400 |
commit | a2cd474a57301ea50c2b7dc921ba678c96d35d45 (patch) | |
tree | 0f1c12e69d24392b631f7b55567f2ac769040820 /meta-python/recipes-devtools/python/python3-simpleeval | |
parent | c956b54ca04dc43c718742fe869af0fa9f5b3c4b (diff) | |
download | meta-openembedded-a2cd474a57301ea50c2b7dc921ba678c96d35d45.tar.gz |
python3-simpleeval: remove 'build' build dependency
In the future we'll have a Python building tool which validates build
requirements. No package should require a specific tool to be present
(not even used, just present), so remove the dependency on 'build'.
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-simpleeval')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch b/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch new file mode 100644 index 0000000000..b090755f8a --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | Upstream-Status: Submitted [https://github.com/danthedeckie/simpleeval/pull/119] | ||
2 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
3 | |||
4 | From 08bc99211aec32882d5f1c83896eb5d72b9fb125 Mon Sep 17 00:00:00 2001 | ||
5 | From: Ross Burton <ross.burton@arm.com> | ||
6 | Date: Mon, 23 May 2022 11:35:00 +0100 | ||
7 | Subject: [PATCH] pyproject.toml: remove build as a build-dependency | ||
8 | |||
9 | pypa/build is one possible build tool, but not the only build tool. Forcing build to be present as a build dependency is meaningless: either the user is using build so obviously have build, or are using something else so having build is irrelevant. | ||
10 | --- | ||
11 | pyproject.toml | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/pyproject.toml b/pyproject.toml | ||
15 | index 052a55a..416482b 100644 | ||
16 | --- a/pyproject.toml | ||
17 | +++ b/pyproject.toml | ||
18 | @@ -1,5 +1,5 @@ | ||
19 | [build-system] | ||
20 | -requires = ["setuptools>=30.3.0", "wheel", "build"] | ||
21 | +requires = ["setuptools>=30.3.0", "wheel"] | ||
22 | build-backend = "setuptools.build_meta" | ||
23 | |||
24 | [tool.black] | ||