diff options
author | Derek Straka <derek@asterius.io> | 2020-02-14 17:56:59 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-15 08:05:07 -0800 |
commit | 90ca842c7a4f08e66cc3d1eb11fc0b3a1129526a (patch) | |
tree | ef70c34859f9eb6b6b1314f2c136ad94e356b3a9 /meta-python/recipes-devtools/python | |
parent | d5df1fe869a9a746438a6ad8c208a170357e7e5a (diff) | |
download | meta-openembedded-90ca842c7a4f08e66cc3d1eb11fc0b3a1129526a.tar.gz |
python3-cmd2: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-cmd2.inc | 13 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb | 20 |
2 files changed, 16 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-cmd2.inc b/meta-python/recipes-devtools/python/python-cmd2.inc deleted file mode 100644 index 68381ad220..0000000000 --- a/meta-python/recipes-devtools/python/python-cmd2.inc +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | SUMMARY = "Extra features for standard library's cmd module" | ||
2 | HOMEPAGE = "http://packages.python.org/cmd2/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9791cd24ca7d1807388ccd55cd066def" | ||
5 | |||
6 | SRC_URI[md5sum] = "6db66a06210d5f1edb44693b887ed62b" | ||
7 | SRC_URI[sha256sum] = "8ad12ef3cc46d03073c545b6e80a3f84a5921f6653073a60e7d9a7ff3b352c9e" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
12 | |||
13 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb b/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb index f5c5c7e1a3..a2bf0c45e2 100644 --- a/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb +++ b/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb | |||
@@ -1,9 +1,21 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "Extra features for standard library's cmd module" |
2 | require python-cmd2.inc | 2 | HOMEPAGE = "http://packages.python.org/cmd2/" |
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9791cd24ca7d1807388ccd55cd066def" | ||
5 | |||
6 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
7 | |||
8 | SRC_URI[md5sum] = "6db66a06210d5f1edb44693b887ed62b" | ||
9 | SRC_URI[sha256sum] = "8ad12ef3cc46d03073c545b6e80a3f84a5921f6653073a60e7d9a7ff3b352c9e" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
3 | 12 | ||
4 | RDEPENDS_${PN} += "\ | 13 | RDEPENDS_${PN} += "\ |
14 | ${PYTHON_PN}-attrs \ | ||
15 | ${PYTHON_PN}-colorama \ | ||
5 | ${PYTHON_PN}-pyperclip \ | 16 | ${PYTHON_PN}-pyperclip \ |
6 | ${PYTHON_PN}-colorama \ | 17 | ${PYTHON_PN}-colorama \ |
7 | ${PYTHON_PN}-attrs \ | ||
8 | ${PYTHON_PN}-wcwidth \ | 18 | ${PYTHON_PN}-wcwidth \ |
9 | " | 19 | " |
20 | |||
21 | BBCLASSEXTEND = "native nativesdk" | ||