diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-02-08 16:14:08 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-02-08 08:51:44 -0800 |
commit | ee424ebd14387b49df00e5c631300adf48ab0223 (patch) | |
tree | 8c739665c1943e73b1d4b45a04d9e6d9c7af72fe /meta-python/recipes-extended/python-meh/python3-meh | |
parent | 9b14ac9f4457865770ffe4e06eae2b9a69e00064 (diff) | |
download | meta-openembedded-ee424ebd14387b49df00e5c631300adf48ab0223.tar.gz |
python3-meh: upgrade 0.50.1 -> 0.51
0001-setup.py-switch-from-distutils-to-setuptools.patch
removed since it's included in 0.51.
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended/python-meh/python3-meh')
-rw-r--r-- | meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch | 31 |
1 files changed, 0 insertions, 31 deletions
diff --git a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch deleted file mode 100644 index 2eb6be5a18..0000000000 --- a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 034ac41561409ffc7836683331b6b94a641436e4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Mon, 28 Feb 2022 09:41:02 -0800 | ||
4 | Subject: [PATCH] setup.py: switch from distutils to setuptools | ||
5 | |||
6 | In Python 3.10 'distutils' is deprecated with removal slated for Python | ||
7 | 3.12. Switch from 'distutils.core' to 'setuptools'. | ||
8 | |||
9 | This also allows for a 'wheel' binary archive format to be built with | ||
10 | 'setup.py bdist_wheel'. | ||
11 | |||
12 | Upstream-Status: Backport [cf9eafdd165347f86bb4a2534c41fd805db52322] | ||
13 | |||
14 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
15 | |||
16 | --- | ||
17 | setup.py | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/setup.py b/setup.py | ||
21 | index 9c12180..3ba5195 100644 | ||
22 | --- a/setup.py | ||
23 | +++ b/setup.py | ||
24 | @@ -1,6 +1,6 @@ | ||
25 | #!/usr/bin/python3 | ||
26 | |||
27 | -from distutils.core import setup | ||
28 | +from setuptools import setup | ||
29 | |||
30 | setup(name='python-meh', version='0.50.1', | ||
31 | description='Python module for handling exceptions', | ||