diff options
author | Derek Straka <derek@asterius.io> | 2025-01-31 01:39:29 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-01-30 18:23:33 -0800 |
commit | 00cb259fbdea566cdcd760d04b23f9feb6f8488c (patch) | |
tree | 2c1945394ff03944e70a4126b270dd90ac34bba1 /meta-python | |
parent | 96c9661005a3bf27a2efb949f2813b86a9461454 (diff) | |
download | meta-openembedded-00cb259fbdea566cdcd760d04b23f9feb6f8488c.tar.gz |
python3-configobj: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rwxr-xr-x | meta-python/recipes-devtools/python/python3-configobj/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb | 16 |
2 files changed, 2 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python3-configobj/run-ptest b/meta-python/recipes-devtools/python/python3-configobj/run-ptest deleted file mode 100755 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-configobj/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb b/meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb index d41d71a4ea..bd4764f4de 100644 --- a/meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb +++ b/meta-python/recipes-devtools/python/python3-configobj_5.0.9.bb | |||
@@ -5,23 +5,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e2df3cb285297a24cd1097dfe6e96f95" | |||
5 | 5 | ||
6 | SRC_URI[sha256sum] = "03c881bbf23aa07bccf1b837005975993c4ab4427ba57f959afdd9d1a2386848" | 6 | SRC_URI[sha256sum] = "03c881bbf23aa07bccf1b837005975993c4ab4427ba57f959afdd9d1a2386848" |
7 | 7 | ||
8 | inherit pypi python_setuptools_build_meta ptest | 8 | inherit pypi python_setuptools_build_meta ptest-python-pytest |
9 | 9 | ||
10 | SRC_URI += " \ | 10 | PTEST_PYTEST_DIR = "src/tests" |
11 | file://run-ptest \ | ||
12 | " | ||
13 | 11 | ||
14 | RDEPENDS:${PN} += " \ | 12 | RDEPENDS:${PN} += " \ |
15 | python3-pprint \ | 13 | python3-pprint \ |
16 | python3-six \ | 14 | python3-six \ |
17 | " | 15 | " |
18 | |||
19 | RDEPENDS:${PN}-ptest += " \ | ||
20 | python3-pytest \ | ||
21 | python3-unittest-automake-output \ | ||
22 | " | ||
23 | |||
24 | do_install_ptest() { | ||
25 | install -d ${D}${PTEST_PATH}/tests | ||
26 | cp -rf ${S}/src/tests/* ${D}${PTEST_PATH}/tests/ | ||
27 | } | ||