diff options
author | Derek Straka <derek@asterius.io> | 2020-02-09 19:40:54 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-09 23:02:39 -0800 |
commit | 04cd18f1d986daa3e7b9802e55d33d03429db4d6 (patch) | |
tree | d89743b9d4af36ff4f52c94f26fa6b91d6d3b964 /meta-python | |
parent | b9db12564a71599dda3ad3b3d5481f9883712238 (diff) | |
download | meta-openembedded-04cd18f1d986daa3e7b9802e55d33d03429db4d6.tar.gz |
python3-attrs: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-attrs.inc | 16 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb | 18 |
2 files changed, 16 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-attrs.inc b/meta-python/recipes-devtools/python/python-attrs.inc deleted file mode 100644 index 35d28a44d0..0000000000 --- a/meta-python/recipes-devtools/python/python-attrs.inc +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | DESCRIPTION = "Classes Without Boilerplate" | ||
2 | HOMEPAGE = "http://www.attrs.org/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d4ab25949a73fe7d4fdee93bcbdbf8ff" | ||
5 | |||
6 | SRC_URI[sha256sum] = "f7b7ce16570fe9965acd6d30101a28f62fb4a7f9e926b3bbc9b61f8b04247e72" | ||
7 | SRC_URI[md5sum] = "5b2db50fcc31be34d32798183c9bd062" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | RDEPENDS_${PN}_class-target += " \ | ||
12 | ${PYTHON_PN}-crypt \ | ||
13 | ${PYTHON_PN}-ctypes \ | ||
14 | " | ||
15 | |||
16 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb b/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb index c34693f506..b3739fda8c 100644 --- a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb +++ b/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb | |||
@@ -1,2 +1,16 @@ | |||
1 | inherit setuptools3 | 1 | DESCRIPTION = "Classes Without Boilerplate" |
2 | require python-attrs.inc | 2 | HOMEPAGE = "http://www.attrs.org/" |
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d4ab25949a73fe7d4fdee93bcbdbf8ff" | ||
5 | |||
6 | SRC_URI[sha256sum] = "f7b7ce16570fe9965acd6d30101a28f62fb4a7f9e926b3bbc9b61f8b04247e72" | ||
7 | SRC_URI[md5sum] = "5b2db50fcc31be34d32798183c9bd062" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | RDEPENDS_${PN}_class-target += " \ | ||
12 | ${PYTHON_PN}-crypt \ | ||
13 | ${PYTHON_PN}-ctypes \ | ||
14 | " | ||
15 | |||
16 | BBCLASSEXTEND = "native" | ||