summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-30 21:57:23 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-30 14:15:34 -0800
commit23d5e7b0bb9e1064838c7815e1e633ee077f61b0 (patch)
treece77ae64ccc245e6ff0d8b0517a506a32aeb932d /meta-python
parent25a4213b12313791c3e80c7186153e8a7b81a3d9 (diff)
downloadmeta-openembedded-23d5e7b0bb9e1064838c7815e1e633ee077f61b0.tar.gz
python3-lz4: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-lz4/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb9
2 files changed, 2 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lz4/run-ptest b/meta-python/recipes-devtools/python/python3-lz4/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-lz4/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb b/meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb
index 746926da4e..7bbe59e8b7 100644
--- a/meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb
@@ -9,24 +9,19 @@ DEPENDS += " \
9 python3-pkgconfig-native \ 9 python3-pkgconfig-native \
10" 10"
11 11
12SRC_URI += "file://run-ptest"
13
14SRC_URI[sha256sum] = "01fe674ef2889dbb9899d8a67361e0c4a2c833af5aeb37dd505727cf5d2a131e" 12SRC_URI[sha256sum] = "01fe674ef2889dbb9899d8a67361e0c4a2c833af5aeb37dd505727cf5d2a131e"
15 13
16inherit pkgconfig pypi python_setuptools_build_meta ptest 14inherit pkgconfig pypi python_setuptools_build_meta ptest-python-pytest
17 15
18RDEPENDS:${PN}-ptest += "\ 16RDEPENDS:${PN}-ptest += "\
19 python3-coverage \ 17 python3-coverage \
20 python3-pytest \
21 python3-pytest-cov \ 18 python3-pytest-cov \
22 python3-pytest-runner \ 19 python3-pytest-runner \
23 python3-multiprocessing \ 20 python3-multiprocessing \
24 python3-psutil \ 21 python3-psutil \
25 python3-unittest-automake-output \
26" 22"
27 23
28do_install_ptest() { 24do_install_ptest:append () {
29 cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
30 # The stream API is experimental and not enabled yet, so don't ship the test suite 25 # The stream API is experimental and not enabled yet, so don't ship the test suite
31 rm -rf ${D}${PTEST_PATH}/tests/stream 26 rm -rf ${D}${PTEST_PATH}/tests/stream
32} 27}