summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-30 21:57:34 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-30 14:15:36 -0800
commit2944028d80c413ffe751e34f1c6393a301346d03 (patch)
treeb994ddfb19ef76f2e90e85bfa8d19c203e52f4f4 /meta-python
parent60a06d274cce46937e8731f1548e149cb4f06ff8 (diff)
downloadmeta-openembedded-2944028d80c413ffe751e34f1c6393a301346d03.tar.gz
python3-flask: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-flask_3.1.0.bb12
2 files changed, 1 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask/run-ptest b/meta-python/recipes-devtools/python/python3-flask/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-flask/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-flask_3.1.0.bb b/meta-python/recipes-devtools/python/python3-flask_3.1.0.bb
index 9b10089c9e..4d1d2d12e6 100644
--- a/meta-python/recipes-devtools/python/python3-flask_3.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-flask_3.1.0.bb
@@ -8,11 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8 8
9SRC_URI[sha256sum] = "5f873c5184c897c8d9d1b05df1e3d01b14910ce69607a117bd3277098a5836ac" 9SRC_URI[sha256sum] = "5f873c5184c897c8d9d1b05df1e3d01b14910ce69607a117bd3277098a5836ac"
10 10
11SRC_URI += " \ 11inherit pypi python_setuptools_build_meta ptest-python-pytest
12 file://run-ptest \
13"
14
15inherit pypi python_setuptools_build_meta ptest
16 12
17CLEANBROKEN = "1" 13CLEANBROKEN = "1"
18 14
@@ -27,10 +23,4 @@ RDEPENDS:${PN} = " \
27 23
28RDEPENDS:${PN}-ptest += "\ 24RDEPENDS:${PN}-ptest += "\
29 python3-asgiref \ 25 python3-asgiref \
30 python3-pytest \
31 python3-unittest-automake-output \
32" 26"
33do_install_ptest() {
34 install -d ${D}${PTEST_PATH}/tests
35 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
36}