diff options
author | Derek Straka <derek@asterius.io> | 2025-01-30 21:57:25 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-01-30 14:15:35 -0800 |
commit | 52650f4003128d15742177a4a88f67e229752bf4 (patch) | |
tree | 580c357ac45aff93c18ded68851d494de6b9f4af /meta-python | |
parent | b1cde973a34b1a89280c39f1b16f7e1401b4ee99 (diff) | |
download | meta-openembedded-52650f4003128d15742177a4a88f67e229752bf4.tar.gz |
python3-iso3166: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-iso3166/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb | 16 |
2 files changed, 1 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python3-iso3166/run-ptest b/meta-python/recipes-devtools/python/python3-iso3166/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-iso3166/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb b/meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb index 3aa084d10a..6b96f5775c 100644 --- a/meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb +++ b/meta-python/recipes-devtools/python/python3-iso3166_2.1.1.bb | |||
@@ -5,21 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5e2f4edc7e7408a82e4a1d05f229b695" | |||
5 | 5 | ||
6 | SRC_URI[sha256sum] = "fcd551b8dda66b44e9f9e6d6bbbee3a1145a22447c0a556e5d0fb1ad1e491719" | 6 | SRC_URI[sha256sum] = "fcd551b8dda66b44e9f9e6d6bbbee3a1145a22447c0a556e5d0fb1ad1e491719" |
7 | 7 | ||
8 | inherit pypi python_setuptools_build_meta ptest | 8 | inherit pypi python_setuptools_build_meta ptest-python-pytest |
9 | |||
10 | SRC_URI += " \ | ||
11 | file://run-ptest \ | ||
12 | " | ||
13 | |||
14 | RDEPENDS:${PN}-ptest += " \ | ||
15 | python3-pytest \ | ||
16 | python3-unittest-automake-output \ | ||
17 | " | ||
18 | |||
19 | do_install_ptest() { | ||
20 | install -d ${D}${PTEST_PATH}/tests | ||
21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
22 | } | ||
23 | 9 | ||
24 | RDEPENDS:${PN} += "python3-numbers" | 10 | RDEPENDS:${PN} += "python3-numbers" |
25 | 11 | ||