diff options
author | Derek Straka <derek@asterius.io> | 2025-01-30 21:57:24 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-01-30 14:15:34 -0800 |
commit | b1cde973a34b1a89280c39f1b16f7e1401b4ee99 (patch) | |
tree | ace834a820e090240bf26acaa38c04baf48a64e5 /meta-python | |
parent | 23d5e7b0bb9e1064838c7815e1e633ee077f61b0 (diff) | |
download | meta-openembedded-b1cde973a34b1a89280c39f1b16f7e1401b4ee99.tar.gz |
python3-jdcal: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-jdcal/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb | 13 |
2 files changed, 2 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jdcal/run-ptest b/meta-python/recipes-devtools/python/python3-jdcal/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-jdcal/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb index d20c9ad42f..d947a73cf0 100644 --- a/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb +++ b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb | |||
@@ -7,21 +7,12 @@ HOMEPAGE = "https://github.com/phn/jdcal" | |||
7 | LICENSE = "BSD-2-Clause" | 7 | LICENSE = "BSD-2-Clause" |
8 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46" | 8 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46" |
9 | 9 | ||
10 | inherit pypi setuptools3 ptest | 10 | inherit pypi setuptools3 ptest-python-pytest |
11 | 11 | ||
12 | SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8" | 12 | SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8" |
13 | 13 | ||
14 | RDEPENDS:${PN} += "python3-compression python3-io python3-pprint python3-shell" | 14 | RDEPENDS:${PN} += "python3-compression python3-io python3-pprint python3-shell" |
15 | 15 | ||
16 | SRC_URI += " \ | 16 | do_install_ptest:append () { |
17 | file://run-ptest \ | ||
18 | " | ||
19 | |||
20 | RDEPENDS:${PN}-ptest += " \ | ||
21 | python3-pytest \ | ||
22 | python3-unittest-automake-output \ | ||
23 | " | ||
24 | |||
25 | do_install_ptest() { | ||
26 | cp -f ${S}/test_jdcal.py ${D}${PTEST_PATH}/ | 17 | cp -f ${S}/test_jdcal.py ${D}${PTEST_PATH}/ |
27 | } | 18 | } |