summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-30 21:57:21 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-30 14:15:34 -0800
commit5678e949e6669fceeaa9af1ff0af8d84fb1241c9 (patch)
treebf139680b0484532ddb8ef6502644982a183d662 /meta-python
parent399675eb7b3d3885b96897879071a7bcae1965bc (diff)
downloadmeta-openembedded-5678e949e6669fceeaa9af1ff0af8d84fb1241c9.tar.gz
python3-multidict: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb13
2 files changed, 1 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict/run-ptest b/meta-python/recipes-devtools/python/python3-multidict/run-ptest
deleted file mode 100644
index d74acaf564..0000000000
--- a/meta-python/recipes-devtools/python/python3-multidict/run-ptest
+++ /dev/null
@@ -1,2 +0,0 @@
1#!/bin/sh
2pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb b/meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb
index 1132e9ba5d..ed49b8ff02 100644
--- a/meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/aio-libs/multidict/"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b4fef6e4b0828c2401fb983363985b39" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=b4fef6e4b0828c2401fb983363985b39"
6 6
7inherit pypi python_setuptools_build_meta ptest 7inherit pypi python_setuptools_build_meta ptest-python-pytest
8 8
9PV .= "+git" 9PV .= "+git"
10 10
@@ -12,19 +12,8 @@ SRCREV = "4140e63780dc6dd600a1837cb9b4c5198c3dcd68"
12PYPI_SRC_URI = "git://github.com/aio-libs/multidict;branch=master;protocol=https" 12PYPI_SRC_URI = "git://github.com/aio-libs/multidict;branch=master;protocol=https"
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \ 15RDEPENDS:${PN}-ptest += " \
20 python3-pytest \
21 python3-pytest-cov \ 16 python3-pytest-cov \
22 python3-unittest-automake-output \
23" 17"
24 18
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
29
30BBCLASSEXTEND = "native nativesdk" 19BBCLASSEXTEND = "native nativesdk"