diff options
author | alperak <alperyasinak1@gmail.com> | 2024-08-07 14:41:48 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-09 14:25:23 -0700 |
commit | c0970f31178b229331c3681dba69fd22b9c26e03 (patch) | |
tree | f0cecea284aa175c90bca4b17609ce11c3b3fdc3 /meta-python | |
parent | b14f6fedf4dd76e178184e9fff206c9d554450e0 (diff) | |
download | meta-openembedded-c0970f31178b229331c3681dba69fd22b9c26e03.tar.gz |
python3-pykickstart: switch to PEP-517 build backend
The project has a proper pyproject.toml which declares the setuptools.build.meta PEP-517 backend.
Fix:
WARNING: python3-pykickstart-3.48-r0 do_check_backend: QA Issue: inherits setuptools3 but has pyproject.toml with setuptools.build_meta, use the correct class [pep517-backend]
Signed-off-by: alperak <alperyasinak1@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb index 953068f7c3..a7bd8ae437 100644 --- a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb +++ b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb | |||
@@ -5,13 +5,13 @@ LICENSE = "GPL-2.0-or-later" | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" |
6 | FILESEXTRAPATHS:prepend := "${THISDIR}/files:" | 6 | FILESEXTRAPATHS:prepend := "${THISDIR}/files:" |
7 | 7 | ||
8 | DEPENDS = "python3" | 8 | inherit python_setuptools_build_meta |
9 | |||
9 | RDEPENDS:${PN} = "python3 \ | 10 | RDEPENDS:${PN} = "python3 \ |
10 | python3-requests \ | 11 | python3-requests \ |
11 | python3-six \ | 12 | python3-six \ |
12 | " | 13 | " |
13 | 14 | ||
14 | S = "${WORKDIR}/git" | ||
15 | SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=master \ | 15 | SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=master \ |
16 | file://0001-support-authentication-for-kickstart.patch \ | 16 | file://0001-support-authentication-for-kickstart.patch \ |
17 | file://0002-pykickstart-parser.py-add-lock-for-readKickstart-and.patch \ | 17 | file://0002-pykickstart-parser.py-add-lock-for-readKickstart-and.patch \ |
@@ -22,4 +22,4 @@ SRCREV = "fa6c80c0e5c6bee29d089899a10d26e6f7f8afd8" | |||
22 | 22 | ||
23 | UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)" | 23 | UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)" |
24 | 24 | ||
25 | inherit setuptools3 | 25 | S = "${WORKDIR}/git" |