diff options
author | Tim Orling <ticotimo@gmail.com> | 2023-04-02 15:29:39 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-04-04 13:39:45 -0700 |
commit | c09cc8dddeecff0572d293ef84aade53b9df2f82 (patch) | |
tree | 5d1ddf92a69268182a922b4117b927232ba78827 /meta-python | |
parent | 80e9601cc87a705f9f9d585fb2aa631e6e7e41db (diff) | |
download | meta-openembedded-c09cc8dddeecff0572d293ef84aade53b9df2f82.tar.gz |
python3-aspectlib: fix ptest
* ptest RDEPENDS on pytest
* Use python3-unittest-automake-output instead of using sed to reformat
the output use this new module.
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-aspectlib/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb | 4 |
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest b/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest index b63c4de0d9..8d2017d39c 100644 --- a/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest +++ b/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb b/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb index 416b031c5e..d2b0864caa 100644 --- a/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb +++ b/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb | |||
@@ -21,8 +21,10 @@ do_install_ptest() { | |||
21 | } | 21 | } |
22 | 22 | ||
23 | RDEPENDS:${PN}-ptest += "\ | 23 | RDEPENDS:${PN}-ptest += "\ |
24 | python3-tornado \ | ||
25 | python3-process-tests \ | 24 | python3-process-tests \ |
25 | python3-pytest \ | ||
26 | python3-tornado \ | ||
27 | python3-unittest-automake-output \ | ||
26 | " | 28 | " |
27 | 29 | ||
28 | RDEPENDS:${PN} += "python3-core python3-fields" | 30 | RDEPENDS:${PN} += "python3-core python3-fields" |