diff options
author | Derek Straka <derek@asterius.io> | 2020-04-04 17:25:57 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-05 10:38:14 -0700 |
commit | f9b8affe0e23cb541a89cd3764a5a70a31298e5d (patch) | |
tree | da2f265681bf84cf2fbc390efb9b8c72a8f48b22 /meta-python | |
parent | 9d4a0b8bfcbf9be6d5a1a9ca92b633aa1d4347aa (diff) | |
download | meta-openembedded-f9b8affe0e23cb541a89cd3764a5a70a31298e5d.tar.gz |
python-pytest-asyncio: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest-asyncio.inc | 13 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb | 15 |
2 files changed, 13 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-asyncio.inc b/meta-python/recipes-devtools/python/python-pytest-asyncio.inc deleted file mode 100644 index 9132c7452c..0000000000 --- a/meta-python/recipes-devtools/python/python-pytest-asyncio.inc +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest" | ||
2 | HOMEPAGE = "https://github.com/pytest-dev/pytest-asyncio" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://README.rst;md5=ae62268d207c73b615fbefddaf91a881" | ||
5 | |||
6 | SRC_URI[md5sum] = "247a7ec32f24a185341327c42a0f85bf" | ||
7 | SRC_URI[sha256sum] = "9fac5100fd716cbecf6ef89233e8590a4ad61d729d1732e0a96b84182df1daaf" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | DEPENDS += "${PYTHON_PN}-pytest-native" | ||
12 | |||
13 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb index 09f26f8d15..a7e963b044 100644 --- a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb +++ b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb | |||
@@ -1,2 +1,13 @@ | |||
1 | inherit setuptools3 | 1 | DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest" |
2 | require python-pytest-asyncio.inc | 2 | HOMEPAGE = "https://github.com/pytest-dev/pytest-asyncio" |
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://README.rst;md5=ae62268d207c73b615fbefddaf91a881" | ||
5 | |||
6 | SRC_URI[md5sum] = "247a7ec32f24a185341327c42a0f85bf" | ||
7 | SRC_URI[sha256sum] = "9fac5100fd716cbecf6ef89233e8590a4ad61d729d1732e0a96b84182df1daaf" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | DEPENDS += "${PYTHON_PN}-pytest-native" | ||
12 | |||
13 | BBCLASSEXTEND = "native" | ||