summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch15
1 files changed, 9 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
index e283b17c45..06dfcdfc60 100644
--- a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
+++ b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
@@ -1,29 +1,32 @@
1From e2d81009c790b4ebeced8408b6bae78060cabcaf Mon Sep 17 00:00:00 2001 1From 24a901fd17926e8e05be4ed2e01b0113a2e3a852 Mon Sep 17 00:00:00 2001
2From: Derek Straka <derek@asterius.io> 2From: Derek Straka <derek@asterius.io>
3Date: Wed, 5 Jul 2017 09:35:51 -0400 3Date: Tue, 19 Dec 2017 11:36:39 -0500
4Subject: [PATCH 1/1] setup.py: remove the setup_requires for setuptools-scm 4Subject: [PATCH] [PATCH 1/1] setup.py: remove the setup_requires for
5 setuptools-scm
5 6
6The setup_requires argument forces the download of the egg file for setuptools-scm 7The setup_requires argument forces the download of the egg file for setuptools-scm
7during the do_compile phase. This download is incompatible with the typical fetch 8during the do_compile phase. This download is incompatible with the typical fetch
8and mirror structure. The only usage of scm is the generation of the _version.py 9and mirror structure. The only usage of scm is the generation of the _version.py
9file and in the release tarball it is already correctly created 10file and in the release tarball it is already correctly created
10 11
12Upstream-Status: Inappropriate [oe specific]
13
11Signed-off-by: Derek Straka <derek@asterius.io> 14Signed-off-by: Derek Straka <derek@asterius.io>
12--- 15---
13 setup.py | 1 - 16 setup.py | 1 -
14 1 file changed, 1 deletion(-) 17 1 file changed, 1 deletion(-)
15 18
16diff --git a/setup.py b/setup.py 19diff --git a/setup.py b/setup.py
17index 751868c..ef6ebf1 100644 20index 3eb38ef..1163202 100644
18--- a/setup.py 21--- a/setup.py
19+++ b/setup.py 22+++ b/setup.py
20@@ -71,7 +71,6 @@ def main(): 23@@ -82,7 +82,6 @@ def main():
21 keywords="test unittest", 24 keywords="test unittest",
22 cmdclass={'test': PyTest}, 25 cmdclass={'test': PyTest},
23 # the following should be enabled for release 26 # the following should be enabled for release
24- setup_requires=['setuptools-scm'], 27- setup_requires=['setuptools-scm'],
28 python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
25 install_requires=install_requires, 29 install_requires=install_requires,
26 extras_require=extras_require, 30 extras_require=extras_require,
27 packages=['_pytest', '_pytest.assertion', '_pytest._code', '_pytest.vendored_packages'],
28-- 31--
292.7.4 322.7.4