diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest.inc | 7 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch | 15 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest_3.2.5.bb | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest_3.3.1.bb | 7 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytest_3.3.1.bb (renamed from meta-python/recipes-devtools/python/python3-pytest_3.2.5.bb) | 0 |
5 files changed, 21 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc index 2f68343f63..90d1a56cae 100644 --- a/meta-python/recipes-devtools/python/python-pytest.inc +++ b/meta-python/recipes-devtools/python/python-pytest.inc | |||
@@ -3,18 +3,21 @@ HOMEPAGE = "http://pytest.org" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c39b24965f4aef64222cb35de9d47cc4" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c39b24965f4aef64222cb35de9d47cc4" |
5 | 5 | ||
6 | SRC_URI[md5sum] = "6dbe9bb093883f75394a689a1426ac6f" | 6 | SRC_URI[md5sum] = "6c056c2c41dfd2a0766682b942abf39c" |
7 | SRC_URI[sha256sum] = "6d5bd4f7113b444c55a3bbb5c738a3dd80d43563d063fc42dcb0aaefbdd78b81" | 7 | SRC_URI[sha256sum] = "cf8436dc59d8695346fcd3ab296de46425ecab00d64096cebe79fb51ecb2eb93" |
8 | 8 | ||
9 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \ | 9 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \ |
10 | file://pytest_version_fix.patch " | 10 | file://pytest_version_fix.patch " |
11 | 11 | ||
12 | RDEPENDS_${PN}_class-target += " \ | 12 | RDEPENDS_${PN}_class-target += " \ |
13 | ${PYTHON_PN}-argparse \ | 13 | ${PYTHON_PN}-argparse \ |
14 | ${PYTHON_PN}-attrs \ | ||
14 | ${PYTHON_PN}-debugger \ | 15 | ${PYTHON_PN}-debugger \ |
15 | ${PYTHON_PN}-json \ | 16 | ${PYTHON_PN}-json \ |
17 | ${PYTHON_PN}-pluggy \ | ||
16 | ${PYTHON_PN}-py \ | 18 | ${PYTHON_PN}-py \ |
17 | ${PYTHON_PN}-setuptools \ | 19 | ${PYTHON_PN}-setuptools \ |
20 | ${PYTHON_PN}-six \ | ||
18 | " | 21 | " |
19 | 22 | ||
20 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:" | 23 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:" |
diff --git a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch index e283b17c45..06dfcdfc60 100644 --- a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch +++ b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch | |||
@@ -1,29 +1,32 @@ | |||
1 | From e2d81009c790b4ebeced8408b6bae78060cabcaf Mon Sep 17 00:00:00 2001 | 1 | From 24a901fd17926e8e05be4ed2e01b0113a2e3a852 Mon Sep 17 00:00:00 2001 |
2 | From: Derek Straka <derek@asterius.io> | 2 | From: Derek Straka <derek@asterius.io> |
3 | Date: Wed, 5 Jul 2017 09:35:51 -0400 | 3 | Date: Tue, 19 Dec 2017 11:36:39 -0500 |
4 | Subject: [PATCH 1/1] setup.py: remove the setup_requires for setuptools-scm | 4 | Subject: [PATCH] [PATCH 1/1] setup.py: remove the setup_requires for |
5 | setuptools-scm | ||
5 | 6 | ||
6 | The setup_requires argument forces the download of the egg file for setuptools-scm | 7 | The setup_requires argument forces the download of the egg file for setuptools-scm |
7 | during the do_compile phase. This download is incompatible with the typical fetch | 8 | during the do_compile phase. This download is incompatible with the typical fetch |
8 | and mirror structure. The only usage of scm is the generation of the _version.py | 9 | and mirror structure. The only usage of scm is the generation of the _version.py |
9 | file and in the release tarball it is already correctly created | 10 | file and in the release tarball it is already correctly created |
10 | 11 | ||
12 | Upstream-Status: Inappropriate [oe specific] | ||
13 | |||
11 | Signed-off-by: Derek Straka <derek@asterius.io> | 14 | Signed-off-by: Derek Straka <derek@asterius.io> |
12 | --- | 15 | --- |
13 | setup.py | 1 - | 16 | setup.py | 1 - |
14 | 1 file changed, 1 deletion(-) | 17 | 1 file changed, 1 deletion(-) |
15 | 18 | ||
16 | diff --git a/setup.py b/setup.py | 19 | diff --git a/setup.py b/setup.py |
17 | index 751868c..ef6ebf1 100644 | 20 | index 3eb38ef..1163202 100644 |
18 | --- a/setup.py | 21 | --- a/setup.py |
19 | +++ b/setup.py | 22 | +++ b/setup.py |
20 | @@ -71,7 +71,6 @@ def main(): | 23 | @@ -82,7 +82,6 @@ def main(): |
21 | keywords="test unittest", | 24 | keywords="test unittest", |
22 | cmdclass={'test': PyTest}, | 25 | cmdclass={'test': PyTest}, |
23 | # the following should be enabled for release | 26 | # the following should be enabled for release |
24 | - setup_requires=['setuptools-scm'], | 27 | - setup_requires=['setuptools-scm'], |
28 | python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*', | ||
25 | install_requires=install_requires, | 29 | install_requires=install_requires, |
26 | extras_require=extras_require, | 30 | extras_require=extras_require, |
27 | packages=['_pytest', '_pytest.assertion', '_pytest._code', '_pytest.vendored_packages'], | ||
28 | -- | 31 | -- |
29 | 2.7.4 | 32 | 2.7.4 |
diff --git a/meta-python/recipes-devtools/python/python-pytest_3.2.5.bb b/meta-python/recipes-devtools/python/python-pytest_3.2.5.bb deleted file mode 100644 index d322f09b24..0000000000 --- a/meta-python/recipes-devtools/python/python-pytest_3.2.5.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit pypi setuptools | ||
2 | require python-pytest.inc | ||
diff --git a/meta-python/recipes-devtools/python/python-pytest_3.3.1.bb b/meta-python/recipes-devtools/python/python-pytest_3.3.1.bb new file mode 100644 index 0000000000..d7bd0a4028 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pytest_3.3.1.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | inherit pypi setuptools | ||
2 | require python-pytest.inc | ||
3 | |||
4 | RDEPENDS_${PN}_class-target += " \ | ||
5 | ${PYTHON_PN}-compiler \ | ||
6 | ${PYTHON_PN}-funcsigs \ | ||
7 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytest_3.2.5.bb b/meta-python/recipes-devtools/python/python3-pytest_3.3.1.bb index 466cfa8253..466cfa8253 100644 --- a/meta-python/recipes-devtools/python/python3-pytest_3.2.5.bb +++ b/meta-python/recipes-devtools/python/python3-pytest_3.3.1.bb | |||