diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch | 20 |
1 files changed, 17 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch b/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch index e50c7e7e24..bb236b4195 100644 --- a/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch +++ b/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch | |||
@@ -1,8 +1,6 @@ | |||
1 | diff --git a/setup.py b/setup.py | ||
2 | index 9a507c6c4..3f5b70866 100644 | ||
3 | --- a/setup.py | 1 | --- a/setup.py |
4 | +++ b/setup.py | 2 | +++ b/setup.py |
5 | @@ -680,7 +680,18 @@ def determine_gl_flags(): | 3 | @@ -695,7 +695,18 @@ def determine_gl_flags(): |
6 | c_options['use_x11'] = True | 4 | c_options['use_x11'] = True |
7 | c_options['use_egl'] = True | 5 | c_options['use_egl'] = True |
8 | else: | 6 | else: |
@@ -22,3 +20,19 @@ index 9a507c6c4..3f5b70866 100644 | |||
22 | return flags, base_flags | 20 | return flags, base_flags |
23 | 21 | ||
24 | 22 | ||
23 | @@ -723,14 +734,13 @@ def determine_sdl2(): | ||
24 | sdl_inc = join(include, 'SDL2') | ||
25 | if isdir(sdl_inc): | ||
26 | sdl2_paths.append(sdl_inc) | ||
27 | - sdl2_paths.extend(['/usr/local/include/SDL2', '/usr/include/SDL2']) | ||
28 | |||
29 | flags['include_dirs'] = sdl2_paths | ||
30 | flags['extra_link_args'] = [] | ||
31 | flags['extra_compile_args'] = [] | ||
32 | flags['library_dirs'] = ( | ||
33 | sdl2_paths if sdl2_paths else | ||
34 | - ['/usr/local/lib/']) | ||
35 | + ['']) | ||
36 | |||
37 | if sdl2_flags: | ||
38 | flags = merge(flags, sdl2_flags) | ||