diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch b/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch new file mode 100644 index 0000000000..276fb50172 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | We don't need to build ninja so there's no need to use scikit-build, | ||
2 | as we just need the python module with it's one ninja() function. | ||
3 | |||
4 | Upstream-Status: Inappropriate | ||
5 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
6 | |||
7 | diff --git a/pyproject.toml b/pyproject.toml | ||
8 | index b895c20..577b642 100644 | ||
9 | --- a/pyproject.toml | ||
10 | +++ b/pyproject.toml | ||
11 | @@ -1,7 +1,6 @@ | ||
12 | [build-system] | ||
13 | requires = [ | ||
14 | "setuptools>=42", | ||
15 | - "scikit-build>=0.12", | ||
16 | ] | ||
17 | build-backend = "setuptools.build_meta" | ||
18 | |||
19 | diff --git a/setup.py b/setup.py | ||
20 | index dbe1fbc..3259754 100755 | ||
21 | --- a/setup.py | ||
22 | +++ b/setup.py | ||
23 | @@ -5,7 +5,7 @@ import os | ||
24 | import sys | ||
25 | from distutils.text_file import TextFile | ||
26 | |||
27 | -from skbuild import setup | ||
28 | +from setuptools import setup | ||
29 | |||
30 | # Add current folder to path | ||
31 | # This is required to import versioneer in an isolated pip build | ||