summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ninja
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ninja')
-rw-r--r--meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch31
-rw-r--r--meta-python/recipes-devtools/python/python3-ninja/run-ninja-from-path.patch39
2 files changed, 67 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch b/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch
new file mode 100644
index 0000000000..276fb50172
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch
@@ -0,0 +1,31 @@
1We don't need to build ninja so there's no need to use scikit-build,
2as we just need the python module with it's one ninja() function.
3
4Upstream-Status: Inappropriate
5Signed-off-by: Ross Burton <ross.burton@arm.com>
6
7diff --git a/pyproject.toml b/pyproject.toml
8index b895c20..577b642 100644
9--- a/pyproject.toml
10+++ b/pyproject.toml
11@@ -1,7 +1,6 @@
12 [build-system]
13 requires = [
14 "setuptools>=42",
15- "scikit-build>=0.12",
16 ]
17 build-backend = "setuptools.build_meta"
18
19diff --git a/setup.py b/setup.py
20index dbe1fbc..3259754 100755
21--- a/setup.py
22+++ b/setup.py
23@@ -5,7 +5,7 @@ import os
24 import sys
25 from distutils.text_file import TextFile
26
27-from skbuild import setup
28+from setuptools import setup
29
30 # Add current folder to path
31 # This is required to import versioneer in an isolated pip build
diff --git a/meta-python/recipes-devtools/python/python3-ninja/run-ninja-from-path.patch b/meta-python/recipes-devtools/python/python3-ninja/run-ninja-from-path.patch
index 26bd037373..0068efcc3a 100644
--- a/meta-python/recipes-devtools/python/python3-ninja/run-ninja-from-path.patch
+++ b/meta-python/recipes-devtools/python/python3-ninja/run-ninja-from-path.patch
@@ -1,7 +1,40 @@
1--- ninja-1.11.1/src/ninja/__init__.py.old 2022-11-05 09:49:23.000000000 +0100 1There's no need to hunt around source or install trees when we're just running ninja
2+++ ninja-1.11.1/src/ninja/__init__.py 2023-03-10 09:45:13.452082888 +0100 2from PATH.
3@@ -44,7 +44,7 @@ 3
4Upstream-Status: Inappropriate
5Signed-off-by: Ross Burton <ross.burton@arm.com>
6
7diff --git a/src/ninja/__init__.py b/src/ninja/__init__.py
8index f83767e..31bb926 100644
9--- a/src/ninja/__init__.py
10+++ b/src/ninja/__init__.py
11@@ -19,32 +19,9 @@ except ImportError:
12 os.path.dirname(__file__), '../../Ninja-src/misc')))
13 from ninja_syntax import Writer, escape, expand # noqa: F401
4 14
15-DATA = os.path.join(os.path.dirname(__file__), 'data')
16-
17-# Support running tests from the source tree
18-if not os.path.exists(DATA):
19- from skbuild.constants import CMAKE_INSTALL_DIR as SKBUILD_CMAKE_INSTALL_DIR
20- from skbuild.constants import set_skbuild_plat_name
21-
22- if platform.system().lower() == "darwin":
23- # Since building the project specifying --plat-name or CMAKE_OSX_* variables
24- # leads to different SKBUILD_DIR, the code below attempt to guess the most
25- # likely plat-name.
26- _skbuild_dirs = os.listdir(os.path.join(os.path.dirname(__file__), '..', '..', '_skbuild'))
27- if _skbuild_dirs:
28- _likely_plat_name = '-'.join(_skbuild_dirs[0].split('-')[:3])
29- set_skbuild_plat_name(_likely_plat_name)
30-
31- _data = os.path.abspath(os.path.join(
32- os.path.dirname(__file__), '..', '..', SKBUILD_CMAKE_INSTALL_DIR(), 'src/ninja/data'))
33- if os.path.exists(_data):
34- DATA = _data
35-
36-BIN_DIR = os.path.join(DATA, 'bin')
37-
5 38
6 def _program(name, args): 39 def _program(name, args):
7- return subprocess.call([os.path.join(BIN_DIR, name)] + args, close_fds=False) 40- return subprocess.call([os.path.join(BIN_DIR, name)] + args, close_fds=False)