summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ujson
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ujson')
-rw-r--r--meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch20
1 files changed, 13 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch
index 47da2b8cfc..42cd99a895 100644
--- a/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch
+++ b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch
@@ -8,22 +8,28 @@ bitbake build errors related to already-stripped.
8 8
9Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> 9Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
10--- 10---
11 setup.py | 2 +- 11 setup.py | 8 +-------
12 1 file changed, 1 insertion(+), 1 deletion(-) 12 1 file changed, 1 insertion(+), 7 deletions(-)
13 13
14diff --git a/setup.py b/setup.py 14diff --git a/setup.py b/setup.py
15index 453dc31..962c507 100644 15index b98963b..d42f07a 100644
16--- a/setup.py 16--- a/setup.py
17+++ b/setup.py 17+++ b/setup.py
18@@ -6,7 +6,7 @@ from setuptools import Extension, setup 18@@ -19,13 +19,7 @@ if not dconv_libs:
19 dconv_source_files = glob("./deps/double-conversion/double-conversion/*.cc") 19 dconv_source_files.extend(glob("./deps/double-conversion/double-conversion/*.cc"))
20 dconv_source_files.append("./lib/dconv_wrapper.cc") 20 dconv_source_files.append("./lib/dconv_wrapper.cc")
21 21
22-strip_flags = ["-Wl,--strip-all"] if platform.system() == "Linux" else [] 22-if platform.system() == "Linux" and environ.get("UJSON_BUILD_NO_STRIP", "0") not in (
23- "1",
24- "True",
25-):
26- strip_flags = ["-Wl,--strip-all"]
27-else:
28- strip_flags = []
23+strip_flags = [] 29+strip_flags = []
24 30
25 module1 = Extension( 31 module1 = Extension(
26 "ujson", 32 "ujson",
27-- 33--
282.30.2 342.25.1
29 35