diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-06-09 09:34:09 +0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-20 19:30:05 +0200 |
commit | 969f1f80bf255498abbec6886d443670c20a79c8 (patch) | |
tree | 45a65f19da61868c2fe71669fb4b7d29b374edac /recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch | |
parent | 648f7b0a2eb202d4378ce50ae566b6ca450dd010 (diff) | |
download | meta-qt5-969f1f80bf255498abbec6886d443670c20a79c8.tar.gz |
Upgrade to Qt 5.9.0
* adapt QtWebEngine recipe to use GN instead of GYP
* add QtRemoteObjects and QtWebView as a new Qt modules
* update available QtBase configure arguments
* remove obsolete patches
* patch all .pc files to remove build paths
* include generated QML cache files in packages
* the patch "configure paths for target qmake properly" could not
be applied anymore and support must be done differently
* QtWebEngine now requires gcc-multilib to be installed on the host
system, because the host tools are built to the same bitness as
the target (arm -> x86, aarch64 -> x86-64)
* refresh the patches to match with b5.9* branches on:
https://github.com/meta-qt5/qtbase
https://github.com/meta-qt5/qtwebengine
and 56-based branch on
https://github.com/meta-qt5/qtwebengine-chromium
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch')
-rw-r--r-- | recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch b/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch new file mode 100644 index 00000000..49fcff6b --- /dev/null +++ b/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From f7c76b91e726a0e63e5226eb6e89b13e0c3509b7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Wed, 7 Jun 2017 13:29:29 +0300 | ||
4 | Subject: [PATCH] Make mapbox-gl build configurable | ||
5 | |||
6 | mapbox-gl-native won't compile for ARMv5 or older, so disable the | ||
7 | build by default. | ||
8 | |||
9 | Task-number: QTBUG-61289 | ||
10 | Change-Id: I5f26200f2735b363c3c322f9035b331b9159c47b | ||
11 | --- | ||
12 | src/plugins/geoservices/geoservices.pro | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/src/plugins/geoservices/geoservices.pro b/src/plugins/geoservices/geoservices.pro | ||
16 | index 0810d39..03fc119 100644 | ||
17 | --- a/src/plugins/geoservices/geoservices.pro | ||
18 | +++ b/src/plugins/geoservices/geoservices.pro | ||
19 | @@ -6,7 +6,7 @@ qtConfig(concurrent) { | ||
20 | SUBDIRS += osm | ||
21 | } | ||
22 | |||
23 | -qtConfig(c++14):!win32|mingw:!qnx { | ||
24 | +mapboxgl:qtConfig(c++14):!win32|mingw:!qnx { | ||
25 | !exists(../../3rdparty/mapbox-gl-native/CMakeLists.txt) { | ||
26 | warning("Submodule mapbox-gl-native does not exist. Run 'git submodule update --init' on qtlocation.") | ||
27 | } else { | ||