diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-06-09 09:34:09 +0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-20 19:30:05 +0200 |
commit | 969f1f80bf255498abbec6886d443670c20a79c8 (patch) | |
tree | 45a65f19da61868c2fe71669fb4b7d29b374edac /recipes-qt/qt5/qtremoteobjects_git.bb | |
parent | 648f7b0a2eb202d4378ce50ae566b6ca450dd010 (diff) | |
download | meta-qt5-969f1f80bf255498abbec6886d443670c20a79c8.tar.gz |
Upgrade to Qt 5.9.0
* adapt QtWebEngine recipe to use GN instead of GYP
* add QtRemoteObjects and QtWebView as a new Qt modules
* update available QtBase configure arguments
* remove obsolete patches
* patch all .pc files to remove build paths
* include generated QML cache files in packages
* the patch "configure paths for target qmake properly" could not
be applied anymore and support must be done differently
* QtWebEngine now requires gcc-multilib to be installed on the host
system, because the host tools are built to the same bitness as
the target (arm -> x86, aarch64 -> x86-64)
* refresh the patches to match with b5.9* branches on:
https://github.com/meta-qt5/qtbase
https://github.com/meta-qt5/qtwebengine
and 56-based branch on
https://github.com/meta-qt5/qtwebengine-chromium
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtremoteobjects_git.bb')
-rw-r--r-- | recipes-qt/qt5/qtremoteobjects_git.bb | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb new file mode 100644 index 00000000..f563818d --- /dev/null +++ b/recipes-qt/qt5/qtremoteobjects_git.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | LICENSE = "BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 ) & ( GPL-2.0+ | LGPL-3.0 ) | The-Qt-Company-Commercial" | ||
2 | LIC_FILES_CHKSUM = " \ | ||
3 | file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
4 | file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \ | ||
5 | file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ | ||
6 | file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ | ||
7 | " | ||
8 | |||
9 | require qt5.inc | ||
10 | require qt5-git.inc | ||
11 | |||
12 | DEPENDS += "qtbase qtdeclarative qtremoteobjects-native" | ||
13 | |||
14 | SRC_URI += " \ | ||
15 | file://0001-Allow-a-tools-only-build.patch \ | ||
16 | " | ||
17 | |||
18 | PACKAGECONFIG ??= "" | ||
19 | PACKAGECONFIG_class-native ??= "tools-only" | ||
20 | PACKAGECONFIG_class-nativesdk ??= "tools-only" | ||
21 | PACKAGECONFIG[tools-only] = "CONFIG+=tools-only" | ||
22 | |||
23 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" | ||
24 | |||
25 | SRCREV = "ae0b101884b05355e3a7bc06dbca722ad3d08d0f" | ||
26 | |||
27 | BBCLASSEXTEND += "native nativesdk" | ||