summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-11-02 19:06:14 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-12 15:01:37 +0100
commitc908fe4ebd5a04813be0b83c173fae182bb22728 (patch)
treeac8f089c2dce89598cf96532eac24cfb33567e4b /recipes-qt/qt5/qtwayland.inc
parent775d77e482f1ea203c78003cccd2547075fd720f (diff)
downloadmeta-qt5-c908fe4ebd5a04813be0b83c173fae182bb22728.tar.gz
qt5: upgrade to 5.2.0
* drop 0027-Fix-misaligned-selection-region-with-text-when-cente.patch resolved in upstream commit 5d8a882c11201a29475c5ea71cfb76c9de6573f5 * drop 0020-Use-BGRA-extension-in-bindTexture.patch resolved in upstream commit e1325cf26e146b68725cc1a0a02b274ce3dfbe5c * drop 0008-wayland-scanner-disable-silent-rules.patch resolved upstream in: commit 2ff2a7c32d76b9e58b800f12469f112cfdb6ad3c Author: Jan Arne Petersen <jan.petersen@kdab.com> Date: Fri Jul 19 14:35:19 2013 +0200 Fix wayland-scanner to work with CONFIG+=silent * squash to match more with structure of https://github.com/meta-qt5/qtbase/tree/stable * qtmodules: bump SRCREVs for 5.2.0 tags now all modules using qt5-git should be newer than any 5.1.* version * qtbase: fix paths in packageconfig *.pc files include- and lib-paths contained build-sysroot paths * qtwebkit: Explicitly add ICU libraries to LIBS fails to build without this * qtjsbackend: remove for git versions Found in [1]: Qt Qml is now using its own built-in Javascript engine and does not depend on V8 anymore. As such the QtJSBackend shared library has disappeared. [1] http://blog.qt.digia.com/blog/2013/09/30/qt-5-2-alpha-available/ * qt5: Upgrade 5.1.1 recipes to 5.2.0 to match git recipes qtjsbackend is now completely gone it allows to share more .patch files and configuration in .inc again Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwayland.inc')
-rw-r--r--recipes-qt/qt5/qtwayland.inc11
1 files changed, 2 insertions, 9 deletions
diff --git a/recipes-qt/qt5/qtwayland.inc b/recipes-qt/qt5/qtwayland.inc
index 15802235..eec26b67 100644
--- a/recipes-qt/qt5/qtwayland.inc
+++ b/recipes-qt/qt5/qtwayland.inc
@@ -7,18 +7,11 @@ LIC_FILES_CHKSUM = "file://${S}/src/compositor/compositor_api/qwaylandsurfacenod
7 7
8# wayland-native is already in wayland DEPENDS, but add it here 8# wayland-native is already in wayland DEPENDS, but add it here
9# explicitly, because it's native wayland-scanner we're looking for 9# explicitly, because it's native wayland-scanner we're looking for
10# libxkbcommon isn't mandatory with 0001-xcbcommon-should-not-be-a-mandatory-dependency.patch 10# libxkbcommon isn't mandatory make it easier to remove by .bbappend
11# make it easier to remove by .bbappend (e.g. for building qtwayland with danny which doesn't 11# (e.g. for building qtwayland with danny which doesn't have libxkbcommon in oe-core).
12# have libxkbcommon in oe-core).
13XKB_DEPENDS = "libxkbcommon xproto" 12XKB_DEPENDS = "libxkbcommon xproto"
14DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native ${XKB_DEPENDS}" 13DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native ${XKB_DEPENDS}"
15 14
16SRC_URI += " \
17 file://0001-xcbcommon-should-not-be-a-mandatory-dependency.patch \
18 file://0002-Temporarily-patching-this-out-as-Qt5.0.0-does-not-ha.patch \
19 file://0003-eglCreateImageKHR-requires-the-context-to-be-NULL.patch \
20"
21
22QT_WAYLAND_CONFIG ?= "wayland-compositor" 15QT_WAYLAND_CONFIG ?= "wayland-compositor"
23QT_WAYLAND_DEFINES ?= "" 16QT_WAYLAND_DEFINES ?= ""
24QT_WAYLAND_BUILD_PARTS ?= "examples" 17QT_WAYLAND_BUILD_PARTS ?= "examples"