summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwayland.inc')
-rw-r--r--recipes-qt/qt5/qtwayland.inc11
1 files changed, 2 insertions, 9 deletions
diff --git a/recipes-qt/qt5/qtwayland.inc b/recipes-qt/qt5/qtwayland.inc
index 15802235..eec26b67 100644
--- a/recipes-qt/qt5/qtwayland.inc
+++ b/recipes-qt/qt5/qtwayland.inc
@@ -7,18 +7,11 @@ LIC_FILES_CHKSUM = "file://${S}/src/compositor/compositor_api/qwaylandsurfacenod
7 7
8# wayland-native is already in wayland DEPENDS, but add it here 8# wayland-native is already in wayland DEPENDS, but add it here
9# explicitly, because it's native wayland-scanner we're looking for 9# explicitly, because it's native wayland-scanner we're looking for
10# libxkbcommon isn't mandatory with 0001-xcbcommon-should-not-be-a-mandatory-dependency.patch 10# libxkbcommon isn't mandatory make it easier to remove by .bbappend
11# make it easier to remove by .bbappend (e.g. for building qtwayland with danny which doesn't 11# (e.g. for building qtwayland with danny which doesn't have libxkbcommon in oe-core).
12# have libxkbcommon in oe-core).
13XKB_DEPENDS = "libxkbcommon xproto" 12XKB_DEPENDS = "libxkbcommon xproto"
14DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native ${XKB_DEPENDS}" 13DEPENDS += "qtbase qtdeclarative wayland wayland-native qtwayland-native ${XKB_DEPENDS}"
15 14
16SRC_URI += " \
17 file://0001-xcbcommon-should-not-be-a-mandatory-dependency.patch \
18 file://0002-Temporarily-patching-this-out-as-Qt5.0.0-does-not-ha.patch \
19 file://0003-eglCreateImageKHR-requires-the-context-to-be-NULL.patch \
20"
21
22QT_WAYLAND_CONFIG ?= "wayland-compositor" 15QT_WAYLAND_CONFIG ?= "wayland-compositor"
23QT_WAYLAND_DEFINES ?= "" 16QT_WAYLAND_DEFINES ?= ""
24QT_WAYLAND_BUILD_PARTS ?= "examples" 17QT_WAYLAND_BUILD_PARTS ?= "examples"