summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch')
-rw-r--r--recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch106
1 files changed, 0 insertions, 106 deletions
diff --git a/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch b/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
deleted file mode 100644
index aa97b56f..00000000
--- a/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
+++ /dev/null
@@ -1,106 +0,0 @@
1From fe9cfbde28c651d00b8f5fda7dc85a97af0c50a1 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 27 Apr 2013 23:15:37 +0200
4Subject: [PATCH] qt_module: Fix pkgconfig and libtool replacements
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9* in situation like this:
10 QT_SYSROOT:/OE/oe-core/tmp-eglibc/sysroots/qemuarm
11 QT_INSTALL_LIBS:/OE/oe-core/tmp-eglibc/sysroots/qemuarm/usr/lib
12 QT_INSTALL_LIBS/raw:/usr/lib
13 QT_INSTALL_LIBS/get:/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/build/lib
14
15 I don't want the replacement like this:
16 sed
17 -e "s,/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/build/include,/usr/include/qt5,g"
18 -e "s,/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/build/lib,/usr/lib,g"
19 "../../lib/pkgconfig/Qt5Core.pc"
20 >"/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/image/OE/oe-core/tmp-eglibc/sysroots/qemuarm/usr/lib/pkgconfig/Qt5Core.pc"
21 because that way I'll end with -L/usr/lib in .pc file which is
22 cross-compile unfriendly, keeping ${libdir}/${includedir} works better
23 in my case
24
25* qt_module: Fix paths in .prl files
26* qmake does not prefix them with QT_SYSROOT when using them
27 so e.g. when building qtdeclarative we get -L/usr/lib to LINKAGE
28 variable, which is unsafe for cross-compilation
29* writting QT_SYSROOT in .prl files is dangerous for sstate when
30 builds are in different directories, so we need
31 SSTATE_SCAN_FILES += "*.pri *.prl"
32 to make them relocateble
33
34* fix paths in packageconfig files
35 This reverts parts of:
36
37 enable path replacement in installed prl files on all platforms
38
39 Task-number: QTBUG-33794
40 Change-Id: Id0d38715673b8a1c0c034e9c15783eb255c4315b
41 Reviewed-by: Joerg Bornemann <joerg.bornemann@digia.com>
42
43* to debug this, rebuild qtbase and read build/src/corelib/Makefile
44* this is example of broken install_target rule (added line feeds):
45 -$(SED) -e s,/OE/5.3.1-r0/build/lib,/usr/lib,g
46 -e 's,/OE/5.3.1-r0/build/include,$$\{includedir},g'
47 -e 's,/OE/5.3.1-r0/build/lib,$$\{libdir},g'
48 "../../lib/pkgconfig/Qt5Core.pc"
49 >"$(INSTALL_ROOT)/usr/lib/pkgconfig/Qt5Core.pc"
50 change .prf files, create copy of WORKDIR, re-excecute only
51 do_configure task and compare generated Makefile, repeat until
52 replace in generated Makefile works ok, then refresh patch and
53 try complete rebuild for qtbase
54* if everything is ok, then try:
55 image $ grep -R "\-L/usr" .
56 image $ grep -R "\-I/usr" .
57 and it should return only few cases of
58 qmake.conf:QMAKE_LFLAGS_THREAD = -L/usr/lib/threads
59 for aix* platformas
60
61Change-Id: Ie1c94b15f2a4e736b65b4d0924d99eb2a7d92a6c
62Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
63Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
64Signed-off-by: Jonathan Liu <net147@gmail.com>
65---
66 mkspecs/features/qt.prf | 13 +++++++++++++
67 mkspecs/features/qt_common.prf | 2 +-
68 2 files changed, 14 insertions(+), 1 deletion(-)
69
70diff --git a/mkspecs/features/qt.prf b/mkspecs/features/qt.prf
71index 98f794c485..bd8b7b52e4 100644
72--- a/mkspecs/features/qt.prf
73+++ b/mkspecs/features/qt.prf
74@@ -315,6 +315,19 @@ contains(TEMPLATE, .*app) {
75 QTPLUGIN = $$manualplugs $$autoplugs
76 }
77
78+contains(TEMPLATE, .*lib) {
79+ pkgconfig_prefix_replace.match = "prefix=$$[QT_SYSROOT]"
80+ pkgconfig_prefix_replace.replace = "prefix="
81+ pkgconfig_prefix_replace.CONFIG = path
82+ QMAKE_PKGCONFIG_INSTALL_REPLACE += pkgconfig_prefix_replace
83+
84+ # drop -L/usr/lib in .prl files
85+ prl_replace.match = "-L\$${libdir}"
86+ prl_replace.replace = ""
87+ prl_replace.CONFIG = path
88+ QMAKE_PRL_INSTALL_REPLACE += prl_replace
89+}
90+
91 QT_PLUGIN_VERIFY = DEPLOYMENT_PLUGIN
92 qtConfig(static) {
93 QT_PLUGIN_VERIFY += QTPLUGIN
94diff --git a/mkspecs/features/qt_common.prf b/mkspecs/features/qt_common.prf
95index d30983f62b..6da07e032c 100644
96--- a/mkspecs/features/qt_common.prf
97+++ b/mkspecs/features/qt_common.prf
98@@ -37,7 +37,7 @@ contains(TEMPLATE, .*lib) {
99 lib_replace.replace =
100 } else {
101 lib_replace.match = $$rplbase/lib
102- lib_replace.replace = $$qqt_libdir
103+ lib_replace.replace = "\$$\\{libdir}"
104 }
105 lib_replace.CONFIG = path
106 QMAKE_PRL_INSTALL_REPLACE += lib_replace