summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-24 12:51:03 +0300
committerAndrei Gherzan <andrei@gherzan.ro>2020-06-24 17:01:17 +0100
commitc482e2cc7c80de7c61075c9e9b3ab073190ece40 (patch)
tree5919d62143c8e8762001caa513aca04cf1c14a90
parent4499d60e60c0c6df6bdcc2425e6d37894e2de550 (diff)
downloadmeta-raspberrypi-c482e2cc7c80de7c61075c9e9b3ab073190ece40.tar.gz
rpi-config: Add ENABLE_IR variable for infrared
Users who want infrared device tree overlays gpio-ir and gpio-ir-tx to be set in config.txt can now easily do it through variable ENABLE_IR, for example in local.conf: ENABLE_IR = "1" By default the GPIO pin for gpio-ir is set to 18 and the pin for gpio-ir-tx is 17. Both pins can be easily changed by modifying variables GPIO_IR and GPIO_IR_TX (for example in local.conf). Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 5315676..d964de5 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -25,6 +25,8 @@ PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
25 25
26VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" 26VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
27VC4DTBO ?= "vc4-kms-v3d" 27VC4DTBO ?= "vc4-kms-v3d"
28GPIO_IR ?= "18"
29GPIO_IR_TX ?= "17"
28 30
29inherit deploy nopackages 31inherit deploy nopackages
30 32
@@ -161,6 +163,13 @@ do_deploy() {
161 echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 163 echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
162 fi 164 fi
163 165
166 # Infrared support
167 if [ "${ENABLE_IR}" = "1" ]; then
168 echo "# Enable infrared" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
169 echo "dtoverlay=gpio-ir,gpio_pin=${GPIO_IR}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
170 echo "dtoverlay=gpio-ir-tx,gpio_pin=${GPIO_IR_TX}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
171 fi
172
164 # VC4 Graphics support 173 # VC4 Graphics support
165 if [ "${VC4GRAPHICS}" = "1" ]; then 174 if [ "${VC4GRAPHICS}" = "1" ]; then
166 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 175 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt