diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-03-16 13:55:35 -0700 |
---|---|---|
committer | Andrei Gherzan <andrei@gherzan.ro> | 2020-03-17 10:33:56 +0000 |
commit | e1bd6d31dcbdf1658dfbe010ec521c8468cacb6f (patch) | |
tree | d566e890d0c6229ce0d8d22bc0c82df0d025aa3d | |
parent | 2aab60f22c042f2514cf090767b228809633616d (diff) | |
download | meta-raspberrypi-e1bd6d31dcbdf1658dfbe010ec521c8468cacb6f.tar.gz |
oeqa: Add rpi specific kernel dmesg parser
These errors are harmless on rpi3/rpi4 [1]
[1] https://github.com/raspberrypi/linux/issues/3195
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | conf/layer.conf | 3 | ||||
-rw-r--r-- | lib/oeqa/runtime/cases/parselogs_rpi.py | 15 |
2 files changed, 18 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf index c836e10..4ed7959 100644 --- a/conf/layer.conf +++ b/conf/layer.conf | |||
@@ -32,3 +32,6 @@ BBFILES_DYNAMIC += " \ | |||
32 | qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \ | 32 | qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \ |
33 | qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \ | 33 | qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \ |
34 | " | 34 | " |
35 | |||
36 | DEFAULT_TEST_SUITES_remove_rpi = "parselogs" | ||
37 | DEFAULT_TEST_SUITES_append_rpi = " parselogs_rpi" | ||
diff --git a/lib/oeqa/runtime/cases/parselogs_rpi.py b/lib/oeqa/runtime/cases/parselogs_rpi.py new file mode 100644 index 0000000..5cf9af1 --- /dev/null +++ b/lib/oeqa/runtime/cases/parselogs_rpi.py | |||
@@ -0,0 +1,15 @@ | |||
1 | from oeqa.runtime.cases.parselogs import * | ||
2 | |||
3 | rpi_errors = [ | ||
4 | 'bcmgenet fd580000.genet: failed to get enet-eee clock', | ||
5 | 'bcmgenet fd580000.genet: failed to get enet-wol clock', | ||
6 | 'bcmgenet fd580000.genet: failed to get enet clock', | ||
7 | ] | ||
8 | |||
9 | ignore_errors['raspberrypi4'] = rpi_errors + common_errors | ||
10 | ignore_errors['raspberrypi4-64'] = rpi_errors + common_errors | ||
11 | ignore_errors['raspberrypi3'] = rpi_errors + common_errors | ||
12 | ignore_errors['raspberrypi3-64'] = rpi_errors + common_errors | ||
13 | |||
14 | class ParseLogsTestRpi(ParseLogsTest): | ||
15 | pass | ||