summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf3
-rw-r--r--lib/oeqa/runtime/cases/parselogs_rpi.py15
2 files changed, 18 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index c836e10..4ed7959 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -32,3 +32,6 @@ BBFILES_DYNAMIC += " \
32 qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \ 32 qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \
33 qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \ 33 qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \
34" 34"
35
36DEFAULT_TEST_SUITES_remove_rpi = "parselogs"
37DEFAULT_TEST_SUITES_append_rpi = " parselogs_rpi"
diff --git a/lib/oeqa/runtime/cases/parselogs_rpi.py b/lib/oeqa/runtime/cases/parselogs_rpi.py
new file mode 100644
index 0000000..5cf9af1
--- /dev/null
+++ b/lib/oeqa/runtime/cases/parselogs_rpi.py
@@ -0,0 +1,15 @@
1from oeqa.runtime.cases.parselogs import *
2
3rpi_errors = [
4 'bcmgenet fd580000.genet: failed to get enet-eee clock',
5 'bcmgenet fd580000.genet: failed to get enet-wol clock',
6 'bcmgenet fd580000.genet: failed to get enet clock',
7]
8
9ignore_errors['raspberrypi4'] = rpi_errors + common_errors
10ignore_errors['raspberrypi4-64'] = rpi_errors + common_errors
11ignore_errors['raspberrypi3'] = rpi_errors + common_errors
12ignore_errors['raspberrypi3-64'] = rpi_errors + common_errors
13
14class ParseLogsTestRpi(ParseLogsTest):
15 pass