summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2025-03-27 19:38:54 +0800
committerArmin Kuster <akuster808@gmail.com>2025-04-13 14:07:57 -0400
commit2dc22272672a466040ccafb5b407b4c4d0ea3b26 (patch)
tree89a0d5654384496b6f97685f7a114b930c84e5d2 /dynamic-layers/meta-python
parent3fcb9c6b208134274274f18e568389b33361772b (diff)
downloadmeta-security-2dc22272672a466040ccafb5b407b4c4d0ea3b26.tar.gz
python3-yamlpath: upgrade 3.8.0 -> 3.8.2
Release note: Enhancements: The MergerConfig class now accepts overrides for config values as "keys" and "rules" keyword arguments to the constructor. Credit and my thanks go to https://github.com/leviem1! BREAKING CHANGES: Support for Python 3.6 has been dropped. This is forced by incompatibilities discovered with the latest version of pytest and because dependencies like dateutil and ruamel-yaml-clib no longer support Python 3.6. Support for Python 3.7 is tepid. While pytest is still working with Python 3.7, other dependencies are no longer supporting Python 3.7; however, the extensive tests for yamlpath show no issues with them, so far. For now, Python 3.12 support is pending, waiting for the dateutil library to resolve a DeprecationWarning regarding its use of datetime.datetime.utcfromtimestamp(). Refer: https://pypi.org/project/yamlpath/3.8.2/ Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'dynamic-layers/meta-python')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.2.bb (renamed from dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.0.bb)7
1 files changed, 6 insertions, 1 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.0.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.2.bb
index 8d5f33e..e2d95ae 100644
--- a/dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.0.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.2.bb
@@ -2,7 +2,7 @@ DESCRIPTION="YAML Path and Command-Line Tools"
2LICENSE = "ISC" 2LICENSE = "ISC"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=5abda174c5040dd12ed2b225e3a096f0" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=5abda174c5040dd12ed2b225e3a096f0"
4 4
5SRC_URI[sha256sum] = "81d5b8baba60c255b519ccd31a691f9bc064223ff196709d41119bde81bba49e" 5SRC_URI[sha256sum] = "4f30cc214b5085d4b0e7756e06c3af3ae589ecde9650d2ada7e1d345ec4fda4f"
6 6
7PYPI_PACKAGE = "yamlpath" 7PYPI_PACKAGE = "yamlpath"
8 8
@@ -11,3 +11,8 @@ inherit pypi python_setuptools_build_meta
11DEPENDS += " \ 11DEPENDS += " \
12 python3-setuptools-scm-native \ 12 python3-setuptools-scm-native \
13" 13"
14RDEPENDS:${PN} += "\
15 python3-datetime \
16 python3-ruamel-yaml \
17 python3-dateutil \
18"