diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-04-15 12:58:46 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-04-15 13:08:41 -0400 |
commit | 34087227ee6bf77eeed6b0728a8c3bb734a6ce35 (patch) | |
tree | ddcc97686bbe6a076325bc69aff56d72590f2be6 | |
parent | 0134bf3a2082939241871bb21ce638175fa99123 (diff) | |
download | meta-virtualization-34087227ee6bf77eeed6b0728a8c3bb734a6ce35.tar.gz |
docker/moby: update to 20.10.6
Bumping to the lastet 20.10 series. This includes the following
moby commits:
255c79a1e8 Move cgroup v2 out of experimental
f2c0b3688a Pin arm64 machines to a specific Ubuntu version
29ff2af2d3 Fix flaky TestInspect
60310e2409 Use docker media type for plugin layers
8088859bab btrfs: Allow unprivileged user to delete subvolumes (kernel >= 4.18)
d22dde8eb1 rootless: fix getCurrentOOMScoreAdj
c1e7924f7c archive: do not use overlayWhiteoutConverter for UserNS
22dc1597b9 overlay2: doesSupportNativeDiff: add fast path for userns
daae27bfce overlay2: call d.naiveDiff.ApplyDiff when useNaiveDiff==true
e974cb638c rootless: bind mount: fix "operation not permitted"
7022b1e12e bump up rootlesskit to v0.14.1
88470052e7 vendor: docker/libnetwork b3507428be5b458cb0e2b4086b13531fb0706e46
d26ed2c33b fix assertPortList normalizing being too strict
915b239519 builder: produce error when using unsupported Dockerfile option
ef2351b416 integration-cli: rely less on "docker port" output format
86d98f5711 integration: update getExternalAddress to prefer IPv4
b41e2d4dc1 integration/container: wrap some long lines for readability
407a61cdb2 hack: use GOPROXY for rootlesskit to workaround issue with old git on CentOS/RHEL 7
a35e1f451e update rootlesskit to v0.14.0
9780942e20 Remove cli test for duplicate --net/--network opts
e1ee2823ec TestPushMultipleTags: Add support for 20.10 CLI
969bde2009 jsonfile: more defensive reader implementation
cb501700e8 Fix handling for json-file io.UnexpectedEOF
2d39a44c1c overlayutils/userxattr.go: add "fast path" for kernel >= 5.11.0
95d2b686be overlay2: support "userxattr" option (kernel 5.11)
074270703c Use buster backports to build with libseccomp-2.4.4
fed6ba2790 Include VPNkit binary for arm64
2ab3cd8c9e update containerd binary to v1.4.4
d3188dc164 Dockerfile: switch to "stable" dockerfile front-end
98273a606a dockerd-rootless-setuptool.sh: create CLI context "rootless"
a0670c6d3d pkg/archive: TestUntarParentPathPermissions requires root
04d9b581e9 Update documentation links
1015b5b438 dockerd-rootless.sh: prohibit running as root
35f5f9e624 builder: fix incorrect cache match for inline cache with empty layers
3ce37a6aa4 vendor: github.com/moby/buildkit v0.8.2
5e8c1b4f7d dockerd-rootless.sh: add typo guard
a24d92f95b check-config.sh: add NETFILTER_XT_MARK
80019e1b0e builder: fix blobs releasing via leases after pull
2a220f1f3d Update Swarmkit to pick up fixes to heartbeat period and stalled tasks
da1a672102 builder: fix pull synchronization regression
0e001154f9 Check the length of the correct variable #42039
3beb2e4422 Move cpu variant checks into platform matcher
0caf485abb Fallback to manifest list when no platform match
a6a88b3145 profiles: seccomp: update to Linux 5.11 syscall list
e3750357a5 builder: ensure libnetwork state file do not leak
ab5711e619 Fix builder inconsistent error on buggy platform
df2a989769 Add shim config for custom runtimes for plugins
d13e162a63 Handle long log messages correctly on SizedLogger
34446d0343 replace json.Unmarshal with NewFromJSON in Create
c00fb1383f docs: fix double "the" in existing API versions
b7e6803ec4 swagger.yaml: Remove extra 'the' wrapped by newline
420de4c569 contrib/check-config.sh: fix INET_XFRM_MODE_TRANSPORT
8412078b1e contrib/check-config.sh: fix IOSCHED_CFQ CFQ_GROUP_IOSCHED
bb0866f04e contrib/check-config.sh: fix MEMCG_SWAP_ENABLED
db47bec3c7 contrib/check-config.sh: fix NF_NAT_NEEDED
6bc47ca4b4 contrib/check-config.sh: fix NF_NAT_IPV4
491642e696 contrib/check-config.sh: support for cgroupv2
cda6988478 Fix Error in daemon_unix.go and docker_cli_run_unit_test.go
1640d7b986 Fix daemon panic when starting container with invalid device cgroup rule
6e3f2acdac docs: fix NanoCPUs casing
ad777ff3bc api: fix NanoCPUs casing in swagger
94d2467613 Fix userns-remap option when username & UID match
acb8a48a3c update runc binary to v1.0.0-rc93
5d442b1cb7 pkg/archive: Unpack() use 0755 permissions for missing directories
5db18e0aba archive: avoid creating parent dirs for XGlobalHeader
94feac18d2 Update rootlesskit to v0.13.1 to fix handling of IPv6 addresses
cc377d27ac Update TestDaemonRestartWithLiveRestore: fix docker0 subnet missmatch Fix docker0 subnet missmatch when running from docker in docker (dind)
fc07fecfb5 TestBuildUserNamespaceValidateCapabilitiesAreV2: verify build completed
f7893961de TestBuildUserNamespaceValidateCapabilitiesAreV2: use correct image name
d31b2141ae Jenkinsfile: add cgroup2
5de9bc7e01 TestInspectOomKilledTrue: skip on cgroup v2
ff49cb3e33 Dockerfile.simple: Fix compile docker binary error with btrfs
49e706e14c Dockerfile.buildx: update buildx to v0.5.1
0211909bde testing: update docker-py 4.4.1
faf6442f80 integration: fix TestBuildUserNamespaceValidateCapabilitiesAreV2 not using frozen image
f0e526f43e Make test work with rootless mode
a287e76e15 pkg/archive: allow mknodding FIFO inside userns
And the following cli commits:
dc017bdda bake: remove windows targets other than windows/amd64
feb6f439e Makefile: have binary, cross, dynbinary targets not use docker for backwards compat
8bc4062fc set default version from git
84cc7d87c update readme with new examples
c1c3d3b3a remove unused targets
048a84614 update circleci cross target
33dacda24 add windows/arm64 target
fcc05e5ea update windows resources generation
58061d25f dockerfile based binary building
4c3b87d92 config.Load() remove unneeded locks
019609872 vendor: github.com/theupdateframework/notary v0.7.0-21-gbf96a202
6ebf76504 vendor: update notary to 5f1f4a34
f508ce9db vendor: github.com/theupdateframework/notary v0.7.0
2c0435431 docs: remove trailing spaces to prevent yamldocs using "compact" notation
ff945151e docs: improve example for "remove all stopped containers"
4571d90f2 config: print deprecation warning when falling back to ~/.dockercfg
f33a69f6e [20.10] Revert "Ignore SIGURG on Linux."
d6eeeb625 service rollback: always verify state
3e157d529 docker service rollback: fix non-zero exit code in some cases
1fdf84b8e fix --update-order and --rollback-order flags
376b99c6d Rename bin/md2man to bin/go-md2man
0de4e6e9a Fix reading context and dockerfile from stdin with BuildKit
de40c2b17 Fix panic when failing to get DefaultAuthConfig
d513e46bf cli/config: prevent warning if HOME is not set
2b74b90ef Add docs and completion for docker node ls --filter node.label
05343b36a fix docker-run man page table formatting
f90db254d docs: Fix wrong variable name
0dcfdde33 Removed format flag for inspect
03cd1dc50 Added zsh completion for docker context subcommands
42811a7eb docs: add redirect for old reference URL
be966aa19 docs: fix typo in deprecated.md
b22fe0fb1 deprecate blkio-weight options with cgroups v1
4eb050071 Update bash completion for fluentd --log-options
08c4fdfa7 Add bash completion for `dockerd --ip6tables`
6aa1b37c8 Add bash completion for `docker run|create --pull`
e82920d76 Remove duplicate word in push.md
82123939f Add bash completion for jobs
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
3 files changed, 31 insertions, 26 deletions
diff --git a/recipes-containers/docker/docker-moby.bb b/recipes-containers/docker/docker-moby.bb index e94dfc2b..31f3ce9f 100644 --- a/recipes-containers/docker/docker-moby.bb +++ b/recipes-containers/docker/docker-moby.bb | |||
@@ -35,16 +35,16 @@ DESCRIPTION = "Linux container runtime \ | |||
35 | # to a docker.inc recipe | 35 | # to a docker.inc recipe |
36 | 36 | ||
37 | # moby commit matches the docker-engine bump on the 19.03 branch' | 37 | # moby commit matches the docker-engine bump on the 19.03 branch' |
38 | SRCREV_moby = "11ecfe8a81b7040738333f777681e55e2a867160" | 38 | SRCREV_moby = "8728dd246c3ab53105434eef8ffe997b6fd14dc6" |
39 | SRCREV_libnetwork = "b3507428be5b458cb0e2b4086b13531fb0706e46" | 39 | SRCREV_libnetwork = "b3507428be5b458cb0e2b4086b13531fb0706e46" |
40 | SRCREV_cli = "41b3ea7e472c504c1b7fe8e3347d329ab97b8112" | 40 | SRCREV_cli = "370c28948e3c12dce3d1df60b6f184990618553f" |
41 | SRC_URI = "\ | 41 | SRC_URI = "\ |
42 | git://github.com/moby/moby.git;branch=20.10;name=moby \ | 42 | git://github.com/moby/moby.git;branch=20.10;name=moby \ |
43 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork \ | 43 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork \ |
44 | git://github.com/docker/cli;branch=20.10;name=cli;destsuffix=git/cli \ | 44 | git://github.com/docker/cli;branch=20.10;name=cli;destsuffix=git/cli \ |
45 | file://docker.init \ | 45 | file://docker.init \ |
46 | file://0001-libnetwork-use-GO-instead-of-go.patch \ | 46 | file://0001-libnetwork-use-GO-instead-of-go.patch \ |
47 | file://0001-cli-use-go-cross-compiler.patch \ | 47 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ |
48 | file://0001-dynbinary-use-go-cross-compiler.patch \ | 48 | file://0001-dynbinary-use-go-cross-compiler.patch \ |
49 | " | 49 | " |
50 | 50 | ||
@@ -58,7 +58,7 @@ GO_IMPORT = "import" | |||
58 | 58 | ||
59 | S = "${WORKDIR}/git" | 59 | S = "${WORKDIR}/git" |
60 | 60 | ||
61 | DOCKER_VERSION = "20.10.3" | 61 | DOCKER_VERSION = "20.10.6" |
62 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" | 62 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" |
63 | 63 | ||
64 | PACKAGES =+ "${PN}-contrib" | 64 | PACKAGES =+ "${PN}-contrib" |
diff --git a/recipes-containers/docker/docker-moby/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch b/recipes-containers/docker/docker-moby/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch new file mode 100644 index 00000000..dc322612 --- /dev/null +++ b/recipes-containers/docker/docker-moby/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 650c882d3c53db118b01dd5e15fa1bc0ddaa36f1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Thu, 15 Apr 2021 11:28:05 -0400 | ||
4 | Subject: [PATCH] cli: use external GO111MODULE and cross compiler | ||
5 | |||
6 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
7 | --- | ||
8 | git/cli/scripts/build/binary | 3 +-- | ||
9 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
10 | |||
11 | diff --git git/cli/scripts/build/binary git/cli/scripts/build/binary | ||
12 | index e4c5e12a6b..7c47b75c2f 100755 | ||
13 | --- git/cli/scripts/build/binary | ||
14 | +++ git/cli/scripts/build/binary | ||
15 | @@ -73,8 +73,7 @@ fi | ||
16 | |||
17 | echo "Building $GO_LINKMODE $(basename "${TARGET}")" | ||
18 | |||
19 | -export GO111MODULE=auto | ||
20 | |||
21 | -go build -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" | ||
22 | +${GO} build -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" | ||
23 | |||
24 | ln -sf "$(basename "${TARGET}")" "$(dirname "${TARGET}")/docker" | ||
25 | -- | ||
26 | 2.19.1 | ||
27 | |||
diff --git a/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch b/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch deleted file mode 100644 index f065e184..00000000 --- a/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | From ae6f4a1e685394fb7b9539f134b66ca84ddc91c2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Tue, 30 Jun 2020 22:19:56 -0400 | ||
4 | Subject: [PATCH] cli: use go cross compiler | ||
5 | |||
6 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
7 | --- | ||
8 | git/cli/scripts/build/dynbinary | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | Index: git/cli/scripts/build/dynbinary | ||
12 | =================================================================== | ||
13 | --- git.orig/cli/scripts/build/dynbinary | ||
14 | +++ git/cli/scripts/build/dynbinary | ||
15 | @@ -19,6 +19,6 @@ | ||
16 | ;; | ||
17 | esac | ||
18 | |||
19 | -go build -o "${TARGET}" -tags pkcs11 --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" | ||
20 | +${GO} build -o "${TARGET}" -tags pkcs11 --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" | ||
21 | |||
22 | ln -sf "$(basename "${TARGET}")" build/docker | ||