diff options
3 files changed, 31 insertions, 26 deletions
diff --git a/recipes-containers/docker/docker-moby.bb b/recipes-containers/docker/docker-moby.bb index e94dfc2b..31f3ce9f 100644 --- a/recipes-containers/docker/docker-moby.bb +++ b/recipes-containers/docker/docker-moby.bb | |||
@@ -35,16 +35,16 @@ DESCRIPTION = "Linux container runtime \ | |||
35 | # to a docker.inc recipe | 35 | # to a docker.inc recipe |
36 | 36 | ||
37 | # moby commit matches the docker-engine bump on the 19.03 branch' | 37 | # moby commit matches the docker-engine bump on the 19.03 branch' |
38 | SRCREV_moby = "11ecfe8a81b7040738333f777681e55e2a867160" | 38 | SRCREV_moby = "8728dd246c3ab53105434eef8ffe997b6fd14dc6" |
39 | SRCREV_libnetwork = "b3507428be5b458cb0e2b4086b13531fb0706e46" | 39 | SRCREV_libnetwork = "b3507428be5b458cb0e2b4086b13531fb0706e46" |
40 | SRCREV_cli = "41b3ea7e472c504c1b7fe8e3347d329ab97b8112" | 40 | SRCREV_cli = "370c28948e3c12dce3d1df60b6f184990618553f" |
41 | SRC_URI = "\ | 41 | SRC_URI = "\ |
42 | git://github.com/moby/moby.git;branch=20.10;name=moby \ | 42 | git://github.com/moby/moby.git;branch=20.10;name=moby \ |
43 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork \ | 43 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork \ |
44 | git://github.com/docker/cli;branch=20.10;name=cli;destsuffix=git/cli \ | 44 | git://github.com/docker/cli;branch=20.10;name=cli;destsuffix=git/cli \ |
45 | file://docker.init \ | 45 | file://docker.init \ |
46 | file://0001-libnetwork-use-GO-instead-of-go.patch \ | 46 | file://0001-libnetwork-use-GO-instead-of-go.patch \ |
47 | file://0001-cli-use-go-cross-compiler.patch \ | 47 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ |
48 | file://0001-dynbinary-use-go-cross-compiler.patch \ | 48 | file://0001-dynbinary-use-go-cross-compiler.patch \ |
49 | " | 49 | " |
50 | 50 | ||
@@ -58,7 +58,7 @@ GO_IMPORT = "import" | |||
58 | 58 | ||
59 | S = "${WORKDIR}/git" | 59 | S = "${WORKDIR}/git" |
60 | 60 | ||
61 | DOCKER_VERSION = "20.10.3" | 61 | DOCKER_VERSION = "20.10.6" |
62 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" | 62 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" |
63 | 63 | ||
64 | PACKAGES =+ "${PN}-contrib" | 64 | PACKAGES =+ "${PN}-contrib" |
diff --git a/recipes-containers/docker/docker-moby/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch b/recipes-containers/docker/docker-moby/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch new file mode 100644 index 00000000..dc322612 --- /dev/null +++ b/recipes-containers/docker/docker-moby/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 650c882d3c53db118b01dd5e15fa1bc0ddaa36f1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Thu, 15 Apr 2021 11:28:05 -0400 | ||
4 | Subject: [PATCH] cli: use external GO111MODULE and cross compiler | ||
5 | |||
6 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
7 | --- | ||
8 | git/cli/scripts/build/binary | 3 +-- | ||
9 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
10 | |||
11 | diff --git git/cli/scripts/build/binary git/cli/scripts/build/binary | ||
12 | index e4c5e12a6b..7c47b75c2f 100755 | ||
13 | --- git/cli/scripts/build/binary | ||
14 | +++ git/cli/scripts/build/binary | ||
15 | @@ -73,8 +73,7 @@ fi | ||
16 | |||
17 | echo "Building $GO_LINKMODE $(basename "${TARGET}")" | ||
18 | |||
19 | -export GO111MODULE=auto | ||
20 | |||
21 | -go build -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" | ||
22 | +${GO} build -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" | ||
23 | |||
24 | ln -sf "$(basename "${TARGET}")" "$(dirname "${TARGET}")/docker" | ||
25 | -- | ||
26 | 2.19.1 | ||
27 | |||
diff --git a/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch b/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch deleted file mode 100644 index f065e184..00000000 --- a/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | From ae6f4a1e685394fb7b9539f134b66ca84ddc91c2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Tue, 30 Jun 2020 22:19:56 -0400 | ||
4 | Subject: [PATCH] cli: use go cross compiler | ||
5 | |||
6 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
7 | --- | ||
8 | git/cli/scripts/build/dynbinary | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | Index: git/cli/scripts/build/dynbinary | ||
12 | =================================================================== | ||
13 | --- git.orig/cli/scripts/build/dynbinary | ||
14 | +++ git/cli/scripts/build/dynbinary | ||
15 | @@ -19,6 +19,6 @@ | ||
16 | ;; | ||
17 | esac | ||
18 | |||
19 | -go build -o "${TARGET}" -tags pkcs11 --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" | ||
20 | +${GO} build -o "${TARGET}" -tags pkcs11 --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" | ||
21 | |||
22 | ln -sf "$(basename "${TARGET}")" build/docker | ||