summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-08-07 00:05:00 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-08-11 15:58:37 -0400
commit681591b5b8879a7607cff8ca5dfb0adf7f69051b (patch)
tree29160a234b87e950fbb29f4d1432beca9e345c27
parentb34307e2f49649aca2f455de8c2ed48eee101138 (diff)
downloadmeta-virtualization-681591b5b8879a7607cff8ca5dfb0adf7f69051b.tar.gz
xen, raspberrypi: bugfix early boot messages: use earlycon=xenboot
Replaces the prior use of earlyprintk which is an x86-specific option. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in2
-rw-r--r--dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend2
2 files changed, 2 insertions, 2 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in b/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in
index 6c38d7d7..84d533a6 100644
--- a/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in
+++ b/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in
@@ -14,7 +14,7 @@ echo Add boot arguments for Xen
14fdt set /chosen xen,xen-bootargs "console=dtuart dtuart=/soc/serial@7e215040 dom0_mem='@@RPI_DOM0_MEM@@' @@RPI_DEBUG_XEN_ARGS@@" 14fdt set /chosen xen,xen-bootargs "console=dtuart dtuart=/soc/serial@7e215040 dom0_mem='@@RPI_DOM0_MEM@@' @@RPI_DEBUG_XEN_ARGS@@"
15 15
16echo Add boot arguments for dom0 16echo Add boot arguments for dom0
17setenv dom0_bootargs "console=hvc0 earlyprintk=xen debug root=/dev/mmcblk0p2 rootwait" 17setenv dom0_bootargs "console=hvc0 earlycon=xenboot debug root=/dev/mmcblk0p2 rootwait"
18fdt set /chosen xen,dom0-bootargs \"${dom0_bootargs}\" 18fdt set /chosen xen,dom0-bootargs \"${dom0_bootargs}\"
19 19
20echo Add a dom0 node to chosen to put Linux boot information in 20echo Add a dom0 node to chosen to put Linux boot information in
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
index 25979e2c..bead4aac 100644
--- a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
+++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -1,5 +1,5 @@
1# For a Xen-enabled distro, override the contents of cmdline.txt 1# For a Xen-enabled distro, override the contents of cmdline.txt
2 2
3DEFAULT_CMDLINE := "${CMDLINE}" 3DEFAULT_CMDLINE := "${CMDLINE}"
4XEN_LINUX_CMDLINE ?= "console=hvc0 clk_ignore_unused earlyprintk=xen debug root=/dev/mmcblk0p2 rootwait" 4XEN_LINUX_CMDLINE ?= "console=hvc0 clk_ignore_unused earlycon=xenboot debug root=/dev/mmcblk0p2 rootwait"
5CMDLINE = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${XEN_LINUX_CMDLINE}', '${DEFAULT_CMDLINE}', d)}" 5CMDLINE = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${XEN_LINUX_CMDLINE}', '${DEFAULT_CMDLINE}', d)}"