diff options
-rw-r--r-- | dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in | 2 | ||||
-rw-r--r-- | dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in b/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in index 6c38d7d7..84d533a6 100644 --- a/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in +++ b/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot.cmd.xen.in | |||
@@ -14,7 +14,7 @@ echo Add boot arguments for Xen | |||
14 | fdt set /chosen xen,xen-bootargs "console=dtuart dtuart=/soc/serial@7e215040 dom0_mem='@@RPI_DOM0_MEM@@' @@RPI_DEBUG_XEN_ARGS@@" | 14 | fdt set /chosen xen,xen-bootargs "console=dtuart dtuart=/soc/serial@7e215040 dom0_mem='@@RPI_DOM0_MEM@@' @@RPI_DEBUG_XEN_ARGS@@" |
15 | 15 | ||
16 | echo Add boot arguments for dom0 | 16 | echo Add boot arguments for dom0 |
17 | setenv dom0_bootargs "console=hvc0 earlyprintk=xen debug root=/dev/mmcblk0p2 rootwait" | 17 | setenv dom0_bootargs "console=hvc0 earlycon=xenboot debug root=/dev/mmcblk0p2 rootwait" |
18 | fdt set /chosen xen,dom0-bootargs \"${dom0_bootargs}\" | 18 | fdt set /chosen xen,dom0-bootargs \"${dom0_bootargs}\" |
19 | 19 | ||
20 | echo Add a dom0 node to chosen to put Linux boot information in | 20 | echo Add a dom0 node to chosen to put Linux boot information in |
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend index 25979e2c..bead4aac 100644 --- a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend +++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend | |||
@@ -1,5 +1,5 @@ | |||
1 | # For a Xen-enabled distro, override the contents of cmdline.txt | 1 | # For a Xen-enabled distro, override the contents of cmdline.txt |
2 | 2 | ||
3 | DEFAULT_CMDLINE := "${CMDLINE}" | 3 | DEFAULT_CMDLINE := "${CMDLINE}" |
4 | XEN_LINUX_CMDLINE ?= "console=hvc0 clk_ignore_unused earlyprintk=xen debug root=/dev/mmcblk0p2 rootwait" | 4 | XEN_LINUX_CMDLINE ?= "console=hvc0 clk_ignore_unused earlycon=xenboot debug root=/dev/mmcblk0p2 rootwait" |
5 | CMDLINE = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${XEN_LINUX_CMDLINE}', '${DEFAULT_CMDLINE}', d)}" | 5 | CMDLINE = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${XEN_LINUX_CMDLINE}', '${DEFAULT_CMDLINE}', d)}" |