diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-09-06 10:28:21 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-09-06 10:57:17 -0400 |
commit | 7b46286b34b35f8c1aba7adcccd1d84bc901caf5 (patch) | |
tree | a765ea3ddf56d00ea12b86dc2d0f0c7c61511bbb | |
parent | 263e4d3d4e36ccdbd660ba252f5eee6309a130cf (diff) | |
download | meta-virtualization-7b46286b34b35f8c1aba7adcccd1d84bc901caf5.tar.gz |
virtual/containerd: don't rprovide virtual/
Similar to the oe-core commit:
commit 93ac180d8c389f16964bce8bd5538d9389e970e6
Author: Michael Opdenacker <michael.opdenacker@bootlin.com>
Date: Wed Sep 1 11:20:20 2021 +0200
meta: stop using "virtual/" in RPROVIDES and RDEPENDS
Fixes [YOCTO #14538]
Recipes shouldn't use the "virtual/" string in RPROVIDES and RDEPENDS.
That's confusing because "virtual/" has no special meaning in
RPROVIDES and RDEPENDS (unlike in PROVIDES and DEPENDS).
Instead, using "virtual-" instead of "virtual/"
as already done in the glibc recipe.
We stop rproviding virtual/containerd to keep the namespace clean.
There aren't many users of this virtual provides, but we keep
it around (for now) to maintain compatibility.
At the same time we convert the RPROVIDES to virtual-containerd, to keep
it available and consistent with oe-core use virtual-libc, etc.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/containerd/containerd-opencontainers_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/cri-o/cri-o_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/docker/docker.inc | 2 | ||||
-rw-r--r-- | recipes-containers/k3s/k3s_git.bb | 2 | ||||
-rw-r--r-- | recipes-core/packagegroups/packagegroup-container.bb | 2 |
5 files changed, 5 insertions, 5 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers_git.bb b/recipes-containers/containerd/containerd-opencontainers_git.bb index 2169f121..b9af08c4 100644 --- a/recipes-containers/containerd/containerd-opencontainers_git.bb +++ b/recipes-containers/containerd/containerd-opencontainers_git.bb | |||
@@ -20,7 +20,7 @@ CONTAINERD_VERSION = "v1.5.5" | |||
20 | EXTRA_OEMAKE += "GODEBUG=1" | 20 | EXTRA_OEMAKE += "GODEBUG=1" |
21 | 21 | ||
22 | PROVIDES += "virtual/containerd" | 22 | PROVIDES += "virtual/containerd" |
23 | RPROVIDES:${PN} = "virtual/containerd" | 23 | RPROVIDES:${PN} = "virtual-containerd" |
24 | 24 | ||
25 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |
26 | 26 | ||
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb index 306f23e8..5cecc26e 100644 --- a/recipes-containers/cri-o/cri-o_git.bb +++ b/recipes-containers/cri-o/cri-o_git.bb | |||
@@ -50,7 +50,7 @@ PNBLACKLIST[cri-o] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'security', bb | |||
50 | 50 | ||
51 | PACKAGES =+ "${PN}-config" | 51 | PACKAGES =+ "${PN}-config" |
52 | 52 | ||
53 | RDEPENDS:${PN} += " virtual/containerd virtual-runc" | 53 | RDEPENDS:${PN} += " virtual-containerd virtual-runc" |
54 | RDEPENDS:${PN} += " e2fsprogs-mke2fs conmon util-linux iptables conntrack-tools" | 54 | RDEPENDS:${PN} += " e2fsprogs-mke2fs conmon util-linux iptables conntrack-tools" |
55 | 55 | ||
56 | inherit systemd | 56 | inherit systemd |
diff --git a/recipes-containers/docker/docker.inc b/recipes-containers/docker/docker.inc index 3c3a0ca7..40a3642c 100644 --- a/recipes-containers/docker/docker.inc +++ b/recipes-containers/docker/docker.inc | |||
@@ -27,7 +27,7 @@ RDEPENDS:${PN} = "util-linux util-linux-unshare iptables \ | |||
27 | bridge-utils \ | 27 | bridge-utils \ |
28 | ca-certificates \ | 28 | ca-certificates \ |
29 | " | 29 | " |
30 | RDEPENDS:${PN} += "virtual/containerd virtual-runc" | 30 | RDEPENDS:${PN} += "virtual-containerd virtual-runc" |
31 | 31 | ||
32 | RRECOMMENDS:${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat kernel-module-nf-conntrack-netlink kernel-module-xt-addrtype kernel-module-xt-masquerade" | 32 | RRECOMMENDS:${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat kernel-module-nf-conntrack-netlink kernel-module-xt-addrtype kernel-module-xt-masquerade" |
33 | 33 | ||
diff --git a/recipes-containers/k3s/k3s_git.bb b/recipes-containers/k3s/k3s_git.bb index 91b73f0b..18d80754 100644 --- a/recipes-containers/k3s/k3s_git.bb +++ b/recipes-containers/k3s/k3s_git.bb | |||
@@ -79,7 +79,7 @@ SYSTEMD_AUTO_ENABLE:${PN}-agent = "disable" | |||
79 | FILES:${PN}-agent = "${BIN_PREFIX}/bin/k3s-agent" | 79 | FILES:${PN}-agent = "${BIN_PREFIX}/bin/k3s-agent" |
80 | FILES:${PN} += "${BIN_PREFIX}/bin/*" | 80 | FILES:${PN} += "${BIN_PREFIX}/bin/*" |
81 | 81 | ||
82 | RDEPENDS:${PN} = "k3s-cni conntrack-tools coreutils findutils iptables iproute2 ipset virtual/containerd" | 82 | RDEPENDS:${PN} = "k3s-cni conntrack-tools coreutils findutils iptables iproute2 ipset virtual-containerd" |
83 | RDEPENDS:${PN}-server = "${PN}" | 83 | RDEPENDS:${PN}-server = "${PN}" |
84 | RDEPENDS:${PN}-agent = "${PN}" | 84 | RDEPENDS:${PN}-agent = "${PN}" |
85 | 85 | ||
diff --git a/recipes-core/packagegroups/packagegroup-container.bb b/recipes-core/packagegroups/packagegroup-container.bb index 5d87e8ec..8d418e95 100644 --- a/recipes-core/packagegroups/packagegroup-container.bb +++ b/recipes-core/packagegroups/packagegroup-container.bb | |||
@@ -42,6 +42,6 @@ RDEPENDS:packagegroup-oci = " \ | |||
42 | " | 42 | " |
43 | 43 | ||
44 | RDEPENDS:packagegroup-containerd = " \ | 44 | RDEPENDS:packagegroup-containerd = " \ |
45 | virtual/containerd \ | 45 | virtual-containerd \ |
46 | " | 46 | " |
47 | 47 | ||