summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2023-12-16 11:26:01 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-01-04 02:52:53 +0000
commit8891c1e02ce93465937a70591effa815a3890796 (patch)
tree31faeb3c76899db4b1c9addb1da607c732f71559
parent33a48549d662bb7f1ac321f43ff2f0f3acfffecb (diff)
downloadmeta-virtualization-8891c1e02ce93465937a70591effa815a3890796.tar.gz
docker-compose: introduce pkgconfig docker-plugin
This allows docker-compose choose to be built as a docker plugin or a standalone binary, in the later case, docker-compose does not have to rdepends on docker, so nother container tools like podman can also use it. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/docker-compose/docker-compose_git.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/recipes-containers/docker-compose/docker-compose_git.bb b/recipes-containers/docker-compose/docker-compose_git.bb
index 092ce3d2..b7745f2b 100644
--- a/recipes-containers/docker-compose/docker-compose_git.bb
+++ b/recipes-containers/docker-compose/docker-compose_git.bb
@@ -34,7 +34,8 @@ COMPATIBLE_HOST = "^(?!mips).*"
34 34
35do_configure[noexec] = "1" 35do_configure[noexec] = "1"
36 36
37PACKAGECONFIG ?= "" 37PACKAGECONFIG ?= "docker-plugin"
38PACKAGECONFIG[docker-plugin] = ",,,docker"
38 39
39include relocation.inc 40include relocation.inc
40 41
@@ -63,16 +64,15 @@ do_compile() {
63} 64}
64 65
65do_install() { 66do_install() {
66 #install -d "${D}${BIN_PREFIX}/bin" 67 if ${@bb.utils.contains('PACKAGECONFIG', 'docker-plugin', 'true', 'false', d)}; then
67 #install -m 755 "${S}/src/import/bin/docker-compose" "${D}${BIN_PREFIX}/bin" 68 install -d ${D}${nonarch_libdir}/docker/cli-plugins
68 69 install -m 755 ${S}/src/import/bin/docker-compose ${D}${nonarch_libdir}/docker/cli-plugins
69 # commonly installed to: /usr/lib/docker/cli-plugins/ 70 else
70 install -d "${D}${nonarch_libdir}/docker/cli-plugins/" 71 install -d ${D}${bindir}
71 install -m 755 "${S}/src/import/bin/docker-compose" "${D}${nonarch_libdir}/docker/cli-plugins/" 72 install -m 755 ${S}/src/import/bin/docker-compose ${D}${bindir}
72 73 fi
73} 74}
74 75
75RDEPENDS:${PN} += " docker"
76 76
77FILES:${PN} += " ${nonarch_libdir}/docker/cli-plugins/" 77FILES:${PN} += " ${nonarch_libdir}/docker/cli-plugins/"
78 78