diff options
-rw-r--r-- | recipes-containers/docker-compose/docker-compose_git.bb | 18 |
1 files changed, 9 insertions, 9 deletions
diff --git a/recipes-containers/docker-compose/docker-compose_git.bb b/recipes-containers/docker-compose/docker-compose_git.bb index 092ce3d2..b7745f2b 100644 --- a/recipes-containers/docker-compose/docker-compose_git.bb +++ b/recipes-containers/docker-compose/docker-compose_git.bb | |||
@@ -34,7 +34,8 @@ COMPATIBLE_HOST = "^(?!mips).*" | |||
34 | 34 | ||
35 | do_configure[noexec] = "1" | 35 | do_configure[noexec] = "1" |
36 | 36 | ||
37 | PACKAGECONFIG ?= "" | 37 | PACKAGECONFIG ?= "docker-plugin" |
38 | PACKAGECONFIG[docker-plugin] = ",,,docker" | ||
38 | 39 | ||
39 | include relocation.inc | 40 | include relocation.inc |
40 | 41 | ||
@@ -63,16 +64,15 @@ do_compile() { | |||
63 | } | 64 | } |
64 | 65 | ||
65 | do_install() { | 66 | do_install() { |
66 | #install -d "${D}${BIN_PREFIX}/bin" | 67 | if ${@bb.utils.contains('PACKAGECONFIG', 'docker-plugin', 'true', 'false', d)}; then |
67 | #install -m 755 "${S}/src/import/bin/docker-compose" "${D}${BIN_PREFIX}/bin" | 68 | install -d ${D}${nonarch_libdir}/docker/cli-plugins |
68 | 69 | install -m 755 ${S}/src/import/bin/docker-compose ${D}${nonarch_libdir}/docker/cli-plugins | |
69 | # commonly installed to: /usr/lib/docker/cli-plugins/ | 70 | else |
70 | install -d "${D}${nonarch_libdir}/docker/cli-plugins/" | 71 | install -d ${D}${bindir} |
71 | install -m 755 "${S}/src/import/bin/docker-compose" "${D}${nonarch_libdir}/docker/cli-plugins/" | 72 | install -m 755 ${S}/src/import/bin/docker-compose ${D}${bindir} |
72 | 73 | fi | |
73 | } | 74 | } |
74 | 75 | ||
75 | RDEPENDS:${PN} += " docker" | ||
76 | 76 | ||
77 | FILES:${PN} += " ${nonarch_libdir}/docker/cli-plugins/" | 77 | FILES:${PN} += " ${nonarch_libdir}/docker/cli-plugins/" |
78 | 78 | ||