diff options
author | Jose Quaresma <quaresma.jose@gmail.com> | 2023-11-28 10:35:48 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-12-04 21:02:21 +0000 |
commit | 9a1f4d91d9f4ed590bf13985dc4b80f8f141aa57 (patch) | |
tree | deb08c946cb021ba42dafd71b19fcac3d62c3294 | |
parent | 0eef35edeeec268ce9bd20e0ad3c9e1e3770496f (diff) | |
download | meta-virtualization-9a1f4d91d9f4ed590bf13985dc4b80f8f141aa57.tar.gz |
docker-compose: drop patches from the removed python version
Drop unused patches from the python version removed in 7bd56074.
https://git.yoctoproject.org/meta-virtualization/commit/recipes-containers/docker-compose?id=7bd56074fece944ef9279d87106eb16452ec6338
Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
2 files changed, 0 insertions, 85 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-import-fastentrypoints.patch b/recipes-containers/docker-compose/files/0001-setup.py-import-fastentrypoints.patch deleted file mode 100644 index df613e84..00000000 --- a/recipes-containers/docker-compose/files/0001-setup.py-import-fastentrypoints.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From f3a22f0f14a4b3313e6405dfb6c97df949493a34 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ming Liu <liu.ming50@gmail.com> | ||
3 | Date: Thu, 30 Jan 2020 17:22:19 +0100 | ||
4 | Subject: [PATCH] setup.py: import fastentrypoints | ||
5 | |||
6 | Upstream-Status: Inappropriate [OE specific configuration] | ||
7 | |||
8 | Signed-off-by: Ming Liu <liu.ming50@gmail.com> | ||
9 | --- | ||
10 | setup.py | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/setup.py b/setup.py | ||
14 | index ad57969..3cccffc 100644 | ||
15 | --- a/setup.py | ||
16 | +++ b/setup.py | ||
17 | @@ -12,7 +12,7 @@ import sys | ||
18 | import pkg_resources | ||
19 | from setuptools import find_packages | ||
20 | from setuptools import setup | ||
21 | - | ||
22 | +import fastentrypoints | ||
23 | |||
24 | def read(*parts): | ||
25 | path = os.path.join(os.path.dirname(__file__), *parts) | ||
26 | -- | ||
27 | 2.7.4 | ||
28 | |||
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch deleted file mode 100644 index 7205d3b5..00000000 --- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | From e3aca6421e003d03d119e69bf3d6b30bb5c662c9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chen Qi <Qi.Chen@windriver.com> | ||
3 | Date: Fri, 22 Nov 2019 09:24:58 +0800 | ||
4 | Subject: [PATCH] setup.py: remove maximum version requirements | ||
5 | |||
6 | Remove maximum version requirements so that docker-compose will not | ||
7 | require old version recipes. | ||
8 | |||
9 | Upstream-Status: Inappropriate [OE Specific] | ||
10 | |||
11 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | ||
12 | Signed-off-by: Ming Liu <liu.ming50@gmail.com> | ||
13 | --- | ||
14 | setup.py | 24 ++++++++++++------------ | ||
15 | 1 file changed, 12 insertions(+), 12 deletions(-) | ||
16 | |||
17 | Index: docker-compose-1.29.1/setup.py | ||
18 | =================================================================== | ||
19 | --- docker-compose-1.29.1.orig/setup.py | ||
20 | +++ docker-compose-1.29.1/setup.py | ||
21 | @@ -25,16 +25,21 @@ | ||
22 | |||
23 | |||
24 | install_requires = [ | ||
25 | - 'docopt >= 0.6.1, < 1', | ||
26 | - 'PyYAML >= 3.10, < 6', | ||
27 | - 'requests >= 2.20.0, < 3', | ||
28 | - 'texttable >= 0.9.0, < 2', | ||
29 | + 'docopt >= 0.6.1', | ||
30 | + 'PyYAML >= 3.10', | ||
31 | + 'requests >= 2.20.0', | ||
32 | + 'texttable >= 0.9.0', | ||
33 | 'websocket-client >= 0.32.0, < 1', | ||
34 | 'distro >= 1.5.0, < 2', | ||
35 | - 'docker[ssh] >= 5', | ||
36 | + 'docker[ssh] >= 4.4.0, < 5', | ||
37 | 'dockerpty >= 0.4.1, < 1', | ||
38 | 'jsonschema >= 2.5.1, < 4', | ||
39 | - 'python-dotenv >= 0.13.0, < 1', | ||
40 | + 'websocket-client >= 0.32.0', | ||
41 | + 'distro >= 1.5.0', | ||
42 | + 'docker[ssh] >= 5', | ||
43 | + 'dockerpty >= 0.4.1', | ||
44 | + 'jsonschema >= 2.5.1', | ||
45 | + 'python-dotenv >= 0.13.0', | ||
46 | ] | ||
47 | |||
48 | |||
49 | @@ -51,7 +56,7 @@ | ||
50 | ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'], | ||
51 | ':python_version < "3.8"': ['cached-property >= 1.2.0, < 2'], | ||
52 | ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], | ||
53 | - 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], | ||
54 | + 'socks': ['PySocks >= 1.5.6, != 1.5.7'], | ||
55 | 'tests': tests_require, | ||
56 | } | ||
57 | |||