summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-02-27 11:32:03 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-02-27 11:46:25 -0500
commit9c686c4bb0620ff87da6a655b552ded4f73c6e23 (patch)
tree54f47c41bc624b4a047f5a8712c3f31e85146172
parent4cbd6c2b467c1f4caa32b2f782072739ab373065 (diff)
downloadmeta-virtualization-9c686c4bb0620ff87da6a655b552ded4f73c6e23.tar.gz
containers: introduce sloci for generating OCI image directories
There are multiple different tools/techniques to generate OCI images. Many of these techniques are part of more complex workflows, or have many options that are needed as part of a larger system or are needed to provide flexibility in the tooling (i.e. they construct the container as well as build the OCI image, or they can push directly to a registry, etc). What we want within the build context of bitbake/oe is to not duplicate work that is done by bitbake, the other image bbclasses or the runtime part of the ecosystem. This means only the construction of an image-spec v1.x image without dependencies on build, or execution of the container within a tool. We'd also like the tool to not pull in multiple, unused dependencies that must be built native/native-sdk, etc, to support the simple use case. The requirements above exclude (for now) tools such as skopeo, umoci, buildah, img, orca-build, kaniko, scratchbuild, etc. Leading us to a from-scratch implementation .. or enter sloci-image. sloci-image is a simple CLI for packing a rootfs into a single layer OCI image. It can easily be extended, or ported to other language implementations in the future. But it brings nearly no native dependencies and is a pure/clean implementation of the image spec that integrates nicely in an oe/bitbake environment. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/sloci-image/sloci-image-native_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-containers/sloci-image/sloci-image-native_git.bb b/recipes-containers/sloci-image/sloci-image-native_git.bb
new file mode 100644
index 00000000..56e8e0f1
--- /dev/null
+++ b/recipes-containers/sloci-image/sloci-image-native_git.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A simple CLI tool for packing rootfs into a single-layer OCI image"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://git/LICENSE;md5=948cd8e59069fad992b0469af9ad7966"
4SRC_URI = "git://github.com/jirutka/sloci-image.git"
5
6DEPENDS = ""
7
8SRCREV = "4015e49763e5a738026a5bbfcf32b38b5a4fa650"
9PV = "v0.1.0+git${SRCPV}"
10
11inherit native
12
13S = "${WORKDIR}"
14
15do_compile() {
16 :
17}
18
19do_install() {
20 cd ${S}/git
21 make PREFIX="${exec_prefix}" DESTDIR=${D} install
22}