summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/sloci-image/sloci-image-native_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-containers/sloci-image/sloci-image-native_git.bb b/recipes-containers/sloci-image/sloci-image-native_git.bb
new file mode 100644
index 00000000..56e8e0f1
--- /dev/null
+++ b/recipes-containers/sloci-image/sloci-image-native_git.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A simple CLI tool for packing rootfs into a single-layer OCI image"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://git/LICENSE;md5=948cd8e59069fad992b0469af9ad7966"
4SRC_URI = "git://github.com/jirutka/sloci-image.git"
5
6DEPENDS = ""
7
8SRCREV = "4015e49763e5a738026a5bbfcf32b38b5a4fa650"
9PV = "v0.1.0+git${SRCPV}"
10
11inherit native
12
13S = "${WORKDIR}"
14
15do_compile() {
16 :
17}
18
19do_install() {
20 cd ${S}/git
21 make PREFIX="${exec_prefix}" DESTDIR=${D} install
22}