summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-03-21 09:30:45 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-03-21 09:49:12 -0400
commit9e4957d36aff17e8c0b22e5499653572cc44adf3 (patch)
tree98395a0ba59afe7448c4901ed740e09673eeb9fb
parent1c424ca4012f43d3f0f94f62118fa7b6bafdf52f (diff)
downloadmeta-virtualization-9e4957d36aff17e8c0b22e5499653572cc44adf3.tar.gz
docker: fixup redepends and clean rsuggests
With the 5.0 kernel and docker 18.09 you can run into issues pulling from docker hub due to an invalid/unknown certificate. We fix that by adding ca-certifcates as a runtime dependency. There can also be isuses setting up the network bridge, so we add bridge-utils to the rdepends. We also add some comments about this recipe and how it should be updated using moby (and why it is like it is). Finally, no one wants rt-tests and lxc when installing docker, so we drop them from the rsuggests. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/docker/docker_git.bb23
1 files changed, 20 insertions, 3 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 47d0c0f8..d3c507ba 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -9,8 +9,8 @@ DESCRIPTION = "Linux container runtime \
9 large-scale web deployments, database clusters, continuous deployment \ 9 large-scale web deployments, database clusters, continuous deployment \
10 systems, private PaaS, service-oriented architectures, etc. \ 10 systems, private PaaS, service-oriented architectures, etc. \
11 . \ 11 . \
12 This package contains the daemon and client. Using docker.io is \ 12 This package contains the daemon and client, which are \
13 officially supported on x86_64 and arm (32-bit) hosts. \ 13 officially supported on x86_64 and arm hosts. \
14 Other architectures are considered experimental. \ 14 Other architectures are considered experimental. \
15 . \ 15 . \
16 Also, note that kernel version 3.10 or above is required for proper \ 16 Also, note that kernel version 3.10 or above is required for proper \
@@ -18,6 +18,22 @@ DESCRIPTION = "Linux container runtime \
18 subtle and/or glaring issues. \ 18 subtle and/or glaring issues. \
19 " 19 "
20 20
21# Notes:
22# - This docker variant uses moby and the other individually maintained
23# upstream variants for SRCREVs
24# - It is a true community / upstream tracking build, and is not a
25# docker curated set of commits or additions
26# - The version number on this package tracks the versions assigned to
27# the curated docker-ce repository. This allows compatibility and
28# functional equivalence, while allowing new features to be more
29# easily added.
30# - This could be called "docker-moby" or just "moby" in the future, but
31# that would require the creation of a virtual/docker dependency, which
32# is possible, but overkill at the moment (while we wait for the upstream
33# to stop changing).
34# - The common components of this recipe and docker-ce do need to be moved
35# to a docker.inc recipe
36
21# moby commit matches the docker-ce swarmkit bump on the 18.09 branch 37# moby commit matches the docker-ce swarmkit bump on the 18.09 branch
22SRCREV_moby = "667e800b2cf920c6d3d7c32fdbc5811934d99769" 38SRCREV_moby = "667e800b2cf920c6d3d7c32fdbc5811934d99769"
23SRCREV_libnetwork = "4725f2163fb214a6312f3beae5991f838ec36326" 39SRCREV_libnetwork = "4725f2163fb214a6312f3beae5991f838ec36326"
@@ -71,11 +87,12 @@ DEPENDS_append_class-target = " lvm2"
71RDEPENDS_${PN} = "util-linux util-linux-unshare iptables \ 87RDEPENDS_${PN} = "util-linux util-linux-unshare iptables \
72 ${@bb.utils.contains('DISTRO_FEATURES', 'aufs', 'aufs-util', '', d)} \ 88 ${@bb.utils.contains('DISTRO_FEATURES', 'aufs', 'aufs-util', '', d)} \
73 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'cgroup-lite', d)} \ 89 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'cgroup-lite', d)} \
90 bridge-utils \
91 ca-certificates \
74 " 92 "
75RDEPENDS_${PN} += "virtual/containerd virtual/runc" 93RDEPENDS_${PN} += "virtual/containerd virtual/runc"
76 94
77RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat docker-init" 95RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat docker-init"
78RSUGGESTS_${PN} = "lxc rt-tests"
79DOCKER_PKG="github.com/docker/docker" 96DOCKER_PKG="github.com/docker/docker"
80 97
81inherit systemd update-rc.d 98inherit systemd update-rc.d